summaryrefslogtreecommitdiff
path: root/media-gfx/jhead/jhead-3.00-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /media-gfx/jhead/jhead-3.00-r2.ebuild
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'media-gfx/jhead/jhead-3.00-r2.ebuild')
-rw-r--r--media-gfx/jhead/jhead-3.00-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/jhead/jhead-3.00-r2.ebuild b/media-gfx/jhead/jhead-3.00-r2.ebuild
new file mode 100644
index 000000000000..4003550535b0
--- /dev/null
+++ b/media-gfx/jhead/jhead-3.00-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare(){
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ eapply "${FILESDIR}/${PN}-2.90-mkstemp_respect_flags.patch"
+ cp "${FILESDIR}/Makefile" makefile || die
+ eapply_user
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ docinto html
+ dodoc *.html
+ doman ${PN}.1
+ doheader ${PN}.h
+ dolib.so lib${PN}.so*
+}