summaryrefslogtreecommitdiff
path: root/media-gfx/iscan-plugin-gt-f500
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/iscan-plugin-gt-f500
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/iscan-plugin-gt-f500')
-rw-r--r--media-gfx/iscan-plugin-gt-f500/Manifest5
-rw-r--r--media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild84
-rw-r--r--media-gfx/iscan-plugin-gt-f500/metadata.xml23
3 files changed, 112 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-f500/Manifest b/media-gfx/iscan-plugin-gt-f500/Manifest
new file mode 100644
index 000000000000..d4ab2aa518a8
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/Manifest
@@ -0,0 +1,5 @@
+DIST iscan-plugin-gt-f500-1.0.0-1.c2.i386.rpm 126130 SHA256 fe87d16ce22c28e2c320286758bea32ea4cad75c83debd6fe95670b704701464 SHA512 efecbb6e3f4fe3f498ebf9bb68a1755405c675d67c52042dcfc2e4e7f98903a870f969b4453d110c9f774452c6ae44042482ee954762c5f5a559e2d3e52a98d0 WHIRLPOOL 11ac8ac1e40b95a2a6128fc3c7fca8c27483c8305f87c989d4102b3d26acd655d7436c7a11547e8c08dac2a488c98b16699e801a5e794f6122935e91116b9bce
+EBUILD iscan-plugin-gt-f500-1.0.0.1-r1.ebuild 2044 SHA256 d8785a1edff3b67527ae1f8417b3e664371478fd275efbd971bf6590d16a2801 SHA512 13cd13f9ce2fb9190afe00116af1c469e76caca24572e0bf0db2f23c2abd1ec4129cc9020fef52a7062dd2f3a8d5d3c57bef700eb3ae1c114fa3ecaac7226e82 WHIRLPOOL 0a7cc0cba543e0c6135c2c29842fa71288010b603f9a142492ec862771e88508c682c00a1f535a639883c7ca454d89b3a82759ba04cdf0ee7a33c33bfd50ebc4
+MISC ChangeLog 2781 SHA256 7932c6468c501d8a42eecc0910d7b115ecb2a9870eabf4322a33b7d125230792 SHA512 6c280d4c73b1b64116b4721d5b5bcd5b8d31bbe1147d673f2f4a0dcc81619da1cd2fb71cd4feb20369e4f62f3a6a8b2046c2d9954e3dd0f6c628c59945b906ff WHIRLPOOL bbdb1a94315312745675524b1b4a69fb480a623d7c9079802f8cc01c2f9b50e42a3c87c53637c0d7b4950a0a63eb783e1e0ade680457451436e4860daf7462a8
+MISC ChangeLog-2015 1501 SHA256 0b329280322b64add89435bbab8f004326a6bf86c59fe15ecd6c41617b62370f SHA512 5e168c5c49f71731de373bc3b12c78549919b573bf82d6c0547937c13079aadeca72ae167f4b1e3f901ba8f5048002f7f4d13d7690d471b41b2d177989976622 WHIRLPOOL ca082d7c47322d55ec29d638511382f9556a02b932320d19a8088e1b8942c1456c2f5041a2770c823961bf5831853b627c7dfffffad060386149b2d904ccd09c
+MISC metadata.xml 718 SHA256 079aab5685fe82fbbdd03cb112716cd630ff3de78c10ddab6bb64540a71b73eb SHA512 4115f0c83b8865fe26ed3a1b796d9491f8fda3c8f03ad611fee755fa91b591f4297656340efc7d4b916a8a215e0ee5d8fea9fc824a5139305fe2a1525b135271 WHIRLPOOL a6708cf469b961222c74e22f630f427c031568e2733ce42443906e699df83db465e3329d849d15a1b161fa4d86e0b59ad0077a73d947b79383aa6064d1a0dbbb
diff --git a/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
new file mode 100644
index 000000000000..ec4ff46f4fda
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/iscan-plugin-gt-f500-1.0.0.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit multilib rpm versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="Epson Perfection 2480/2580 PHOTO scanner plugin for SANE 'epkowa' backend"
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="https://dev.gentoo.org/~flameeyes/avasys/${MY_P}.c2.i386.rpm"
+
+LICENSE="EPSON EAPL"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE="minimal"
+
+DEPEND="minimal? ( >=media-gfx/iscan-2.21.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # install scanner firmware
+ insinto /usr/share/iscan
+ doins "${WORKDIR}/usr/share/iscan/"*
+
+ dodoc usr/share/doc/*/*
+
+ use minimal && return
+ # install scanner plugins
+ exeinto /opt/iscan/esci
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmds=(
+ "iscan-registry --COMMAND interpreter usb 0x04b8 0x0121 '/opt/iscan/esci/libesint41.so.2 /usr/share/iscan/esfw41.bin'"
+ )
+}
+
+pkg_postinst() {
+ elog
+ elog "Firmware file esfw41.bin for Epson Perfection 2480/2580 PHOTO"
+ elog "has been installed in /usr/share/iscan."
+ elog
+ use minimal && return
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ # Needed for scanner to work properly.
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/add}
+ done
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/add}"
+ done
+ fi
+}
+
+pkg_prerm() {
+ use minimal && return
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ for basecmd in "${basecmds[@]}"; do
+ eval ${basecmd/COMMAND/remove}
+ done
+ else
+ ewarn "Unable to de-register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ for basecmd in "${basecmds[@]}"; do
+ ewarn "${basecmd/COMMAND/remove}"
+ done
+ fi
+}
diff --git a/media-gfx/iscan-plugin-gt-f500/metadata.xml b/media-gfx/iscan-plugin-gt-f500/metadata.xml
new file mode 100644
index 000000000000..c1744e26e874
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f500/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit only.
+
+ Also includes the firmware for them, to be used with the snapscan
+ SANE backend (provided by <pkg>media-gfx/sane-backends</pkg>).
+
+ Supports the following models:
+
+ EPSON Perfection 2480 PHOTO / GT-F500
+ EPSON Perfection 2580 PHOTO / GT-F550
+ </longdescription>
+
+ <use>
+ <flag name="minimal">
+ Install the firmware only, and not the plugin.
+ </flag>
+ </use>
+</pkgmetadata>