summaryrefslogtreecommitdiff
path: root/media-gfx/imv/imv-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /media-gfx/imv/imv-4.3.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'media-gfx/imv/imv-4.3.0.ebuild')
-rw-r--r--media-gfx/imv/imv-4.3.0.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/media-gfx/imv/imv-4.3.0.ebuild b/media-gfx/imv/imv-4.3.0.ebuild
deleted file mode 100644
index 992772d5dd6e..000000000000
--- a/media-gfx/imv/imv-4.3.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson xdg
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.sr.ht/~exec64/imv/"
-else
- SRC_URI="https://github.com/eXeC64/imv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Minimal image viewer designed for tiling window manager users"
-HOMEPAGE="https://sr.ht/~exec64/imv/"
-
-LICENSE="MIT-with-advertising"
-SLOT="0"
-IUSE="+X +freeimage gif heif jpeg png svg test tiff wayland"
-REQUIRED_USE="|| ( X wayland )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/icu:=
- dev-libs/inih
- media-libs/libglvnd[X?]
- x11-libs/cairo
- x11-libs/libxkbcommon[X?]
- x11-libs/pango
- X? (
- x11-libs/libX11
- x11-libs/libxcb:=
- )
- freeimage? ( media-libs/freeimage )
- gif? ( media-libs/libnsgif )
- heif? ( media-libs/libheif:= )
- jpeg? ( media-libs/libjpeg-turbo:= )
- png? ( media-libs/libpng:= )
- svg? ( >=gnome-base/librsvg-2.44 )
- tiff? ( media-libs/tiff )
- wayland? ( dev-libs/wayland )
- !sys-apps/renameutils"
-DEPEND="
- ${RDEPEND}
- X? ( x11-base/xorg-proto )
- test? ( dev-util/cmocka )"
-BDEPEND="
- app-text/asciidoc
- wayland? ( dev-util/wayland-scanner )"
-
-src_prepare() {
- default
-
- # if wayland-only, don't automagic on libGL and force libOpenGL
- if ! use X; then
- sed -i "/dependency('gl'/{s/'gl'/'opengl'/;s/false/true/}" meson.build || die
- fi
-
- # glu isn't used by anything
- sed -i "/dependency('glu')/d" meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature freeimage)
- $(meson_feature gif libnsgif)
- $(meson_feature heif libheif)
- $(meson_feature jpeg libjpeg)
- $(meson_feature png libpng)
- $(meson_feature svg librsvg)
- $(meson_feature test)
- $(meson_feature tiff libtiff)
- -Dwindows=$(usex X $(usex wayland all x11) wayland)
- )
-
- meson_src_configure
-}