summaryrefslogtreecommitdiff
path: root/media-gfx/img2pdf/img2pdf-0.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /media-gfx/img2pdf/img2pdf-0.3.6.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'media-gfx/img2pdf/img2pdf-0.3.6.ebuild')
-rw-r--r--media-gfx/img2pdf/img2pdf-0.3.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-gfx/img2pdf/img2pdf-0.3.6.ebuild b/media-gfx/img2pdf/img2pdf-0.3.6.ebuild
new file mode 100644
index 000000000000..612d1425962d
--- /dev/null
+++ b/media-gfx/img2pdf/img2pdf-0.3.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Losslessly convert raster images to PDF"
+HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-python/pillow[${PYTHON_USEDEP},tiff,zlib] )"
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py