summaryrefslogtreecommitdiff
path: root/media-gfx/imagemagick/imagemagick-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /media-gfx/imagemagick/imagemagick-9999.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'media-gfx/imagemagick/imagemagick-9999.ebuild')
-rw-r--r--media-gfx/imagemagick/imagemagick-9999.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/media-gfx/imagemagick/imagemagick-9999.ebuild b/media-gfx/imagemagick/imagemagick-9999.ebuild
index 1d5c3d2d7d7c..8d8ee8a769b2 100644
--- a/media-gfx/imagemagick/imagemagick-9999.ebuild
+++ b/media-gfx/imagemagick/imagemagick-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit eapi7-ver eutils flag-o-matic libtool perl-functions toolchain-funcs multilib
+inherit flag-o-matic libtool perl-functions toolchain-funcs multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/ImageMagick/ImageMagick.git"
@@ -20,8 +20,16 @@ DESCRIPTION="A collection of tools and libraries for many image formats"
HOMEPAGE="https://www.imagemagick.org/"
LICENSE="imagemagick"
-SLOT="0/${PV}"
+SLOT="0/7.0.9"
IUSE="bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="corefonts? ( truetype )
+ test? ( corefonts )"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
RDEPEND="
dev-libs/libltdl:0
@@ -62,14 +70,11 @@ RDEPEND="
xml? ( dev-libs/libxml2:= )
lzma? ( app-arch/xz-utils )
zlib? ( sys-libs/zlib:= )"
+
DEPEND="${RDEPEND}
!media-gfx/graphicsmagick[imagemagick]
- virtual/pkgconfig
X? ( x11-base/xorg-proto )"
-REQUIRED_USE="corefonts? ( truetype )
- test? ( corefonts )"
-
S="${WORKDIR}/${MY_P}"
src_prepare() {
@@ -150,6 +155,7 @@ src_configure() {
$(use_with jbig)
$(use_with jpeg)
$(use_with jpeg2k openjp2)
+ --without-jxl
$(use_with lcms)
$(use_with lqr)
$(use_with lzma)
@@ -200,7 +206,7 @@ src_install() {
DOCUMENTATION_PATH="${EPREFIX}"/usr/share/doc/${PF}/html \
install
- rm -f "${ED%/}"/usr/share/doc/${PF}/html/{ChangeLog,LICENSE,NEWS.txt}
+ rm -f "${ED}"/usr/share/doc/${PF}/html/{ChangeLog,LICENSE,NEWS.txt}
dodoc {AUTHORS,README}.txt ChangeLog
if use perl; then