summaryrefslogtreecommitdiff
path: root/media-gfx/grub-splashes/grub-splashes-20091109.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/grub-splashes/grub-splashes-20091109.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/grub-splashes/grub-splashes-20091109.ebuild')
-rw-r--r--media-gfx/grub-splashes/grub-splashes-20091109.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/grub-splashes/grub-splashes-20091109.ebuild b/media-gfx/grub-splashes/grub-splashes-20091109.ebuild
new file mode 100644
index 000000000000..3c80c5241972
--- /dev/null
+++ b/media-gfx/grub-splashes/grub-splashes-20091109.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mount-boot
+
+DESCRIPTION="Collection of grub splashes"
+HOMEPAGE="https://dev.gentoo.org/~welp/grub-splashes.xml"
+SRC_URI="mirror://gentoo/${PN}-0.1.tar.gz
+ http://www.kde-look.org/CONTENT/content-files/49074-natural_gentoo-8.0.tar.gz
+ http://www.kde-look.org/CONTENT/content-files/98478-gentoo-splash.xpm.gz"
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp "${DISTDIR}"/98478-gentoo-splash.xpm.gz gentoo-blue.xpm.gz
+}
+
+src_install() {
+ insinto /boot/grub
+ find . -name '*.xpm.gz' -exec doins {} \;
+}
+
+pkg_postinst() {
+ elog "Please note that this ebuild makes the assumption that you're"
+ elog "using /boot/grub/ for your grub configuration."
+ elog ""
+ elog "To use your new grub splashes edit your /boot/grub/grub.conf"
+ elog "You can see available splash screens by running"
+ elog "\`ls /boot/grub/ | grep xpm\`"
+}