summaryrefslogtreecommitdiff
path: root/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
commit0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (patch)
tree15bb76d57cfb8652fd2627a24007e0bb92ec4a99 /media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
parent5b5df25227111ef465caf5c52bcfb66dac3219cd (diff)
gentoo resync : 21.01.2018
Diffstat (limited to 'media-gfx/graphicsmagick/graphicsmagick-9999.ebuild')
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-9999.ebuild72
1 files changed, 37 insertions, 35 deletions
diff --git a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
index aecb472c7108..c5f11fb693d3 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -74,41 +74,43 @@ src_configure() {
openmp=enable
fi
- econf \
- --${openmp}-openmp \
- --enable-largefile \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug prof) \
- $(use_enable debug gcov) \
- $(use_enable imagemagick magick-compat) \
- $(use_with threads) \
- $(use_with modules) \
- --with-quantum-depth=${depth} \
- --without-frozenpaths \
- $(use_with cxx magick-plus-plus) \
- $(use_with perl) \
- --with-perl-options=INSTALLDIRS=vendor \
- $(use_with bzip2 bzlib) \
- $(use_with postscript dps) \
- $(use_with fpx) \
- --without-gslib \
- $(use_with jbig) \
- $(use_with webp) \
- $(use_with jpeg) \
- $(use_with jpeg2k jp2) \
- $(use_with lcms lcms2) \
- $(use_with lzma) \
- $(use_with png) \
- $(use_with tiff) \
- $(use_with truetype ttf) \
- $(use_with wmf) \
- --with-fontpath="${EPREFIX}"/usr/share/fonts \
- --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts \
- --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts \
- $(use_with svg xml) \
- $(use_with zlib) \
+ local myeconfargs=(
+ --${openmp}-openmp
+ --enable-largefile
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable debug prof)
+ $(use_enable debug gcov)
+ $(use_enable imagemagick magick-compat)
+ $(use_with threads)
+ $(use_with modules)
+ --with-quantum-depth=${depth}
+ --without-frozenpaths
+ $(use_with cxx magick-plus-plus)
+ $(use_with perl)
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_with bzip2 bzlib)
+ $(use_with postscript dps)
+ $(use_with fpx)
+ --without-gslib
+ $(use_with jbig)
+ $(use_with webp)
+ $(use_with jpeg)
+ $(use_with jpeg2k jp2)
+ $(use_with lcms lcms2)
+ $(use_with lzma)
+ $(use_with png)
+ $(use_with tiff)
+ $(use_with truetype ttf)
+ $(use_with wmf)
+ --with-fontpath="${EPREFIX}"/usr/share/fonts
+ --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
+ --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
+ $(use_with svg xml)
+ $(use_with zlib)
$(use_with X x)
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {