summaryrefslogtreecommitdiff
path: root/media-gfx/gimp/gimp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-gfx/gimp/gimp-9999.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-gfx/gimp/gimp-9999.ebuild')
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
index c7e793bb2d56..28a370966ece 100644
--- a/media-gfx/gimp/gimp-9999.ebuild
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
LUA_COMPAT=( luajit )
PYTHON_COMPAT=( python3_{8..10} )
@@ -39,11 +39,11 @@ COMMON_DEPEND="
dev-libs/libxslt
>=gnome-base/librsvg-2.40.21:2
>=media-gfx/mypaint-brushes-2.0.2:=
- >=media-libs/babl-0.1.88[introspection,lcms,vala?]
+ >=media-libs/babl-0.1.90[introspection,lcms,vala?]
>=media-libs/fontconfig-2.12.6
>=media-libs/freetype-2.10.2
- >=media-libs/gegl-0.4.34:0.4[cairo,introspection,lcms,vala?]
- >=media-libs/gexiv2-0.10.10
+ >=media-libs/gegl-0.4.36:0.4[cairo,introspection,lcms,vala?]
+ >=media-libs/gexiv2-0.12.2
>=media-libs/harfbuzz-2.6.5:=
>=media-libs/lcms-2.9:2
>=media-libs/libmypaint-1.6.1:=
@@ -108,7 +108,7 @@ DEPEND="
# TODO: there are probably more atoms in DEPEND which should be in BDEPEND now
BDEPEND="virtual/pkgconfig"
-DOCS=( "AUTHORS" "HACKING" "NEWS" "README" "README.i18n" )
+DOCS=( "AUTHORS" "devel-docs/CODING_STYLE.md" "devel-docs/HACKING.md" "NEWS" "README" "README.i18n" )
# Bugs 685210 (and duplicate 691070)
PATCHES=(
@@ -131,8 +131,6 @@ src_prepare() {
gnome2_src_prepare # calls eautoreconf
- use vala && vala_src_prepare
-
sed 's:-DGIMP_protect_DISABLE_DEPRECATED:-DGIMP_DISABLE_DEPRECATED:g' -i configure || die #615144
fgrep -q GIMP_DISABLE_DEPRECATED configure || die #615144, self-test
@@ -156,6 +154,8 @@ _adjust_sandbox() {
src_configure() {
_adjust_sandbox
+ use vala && vala_setup
+
local myconf=(
GEGL="${EPREFIX}"/usr/bin/gegl-0.4
GDBUS_CODEGEN="${EPREFIX}"/usr/bin/gdbus-codegen