summaryrefslogtreecommitdiff
path: root/media-gfx/gif2apng/gif2apng-1.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/gif2apng/gif2apng-1.9-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/gif2apng/gif2apng-1.9-r1.ebuild')
-rw-r--r--media-gfx/gif2apng/gif2apng-1.9-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-gfx/gif2apng/gif2apng-1.9-r1.ebuild b/media-gfx/gif2apng/gif2apng-1.9-r1.ebuild
new file mode 100644
index 000000000000..9e8aa44e1c0b
--- /dev/null
+++ b/media-gfx/gif2apng/gif2apng-1.9-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from a GIF"
+HOMEPAGE="https://sourceforge.net/projects/gif2apng/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="ZLIB LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ app-arch/zopfli:="
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_prepare() {
+ default
+
+ # remove bundled libs
+ rm -r zlib zopfli || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}