summaryrefslogtreecommitdiff
path: root/media-gfx/fotowall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /media-gfx/fotowall
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'media-gfx/fotowall')
-rw-r--r--media-gfx/fotowall/Manifest3
-rw-r--r--media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch28
-rw-r--r--media-gfx/fotowall/fotowall-1.0.ebuild4
3 files changed, 33 insertions, 2 deletions
diff --git a/media-gfx/fotowall/Manifest b/media-gfx/fotowall/Manifest
index bfa36f23129e..c75baad5cfb1 100644
--- a/media-gfx/fotowall/Manifest
+++ b/media-gfx/fotowall/Manifest
@@ -1,3 +1,4 @@
+AUX fotowall-1.0-qt-5.11.patch 585 BLAKE2B a630a7bc8b152eb342e96e94febb980852f4f29dfb4465b5fd7e21ab9eaed08cf0d96fca309e732dec09e3e76a69ffabd98bd376f7bd82ac51fcd1fc0d0471ba SHA512 10c7e9a842b5318dd8e0708f5c876b5494ed273d5509dfcfcb428c0c42c5483d82c3239c1c4cbdd60ee5e6cb5d391079fc684f0c4df992511992d20c02fecdd6
DIST fotowall-1.0.tar.gz 1672398 BLAKE2B 8665f30b11c2fe1e6661e7655dd4de35c3b8bc1d29926d9155958ce5e8875f16281b150e710e4b94e82279e86c510c9933389df32d3255416b6ccdd53fd9c656 SHA512 ae2d887affd28d21b9caabbb3508d8ebd64058d81f84d3b3d67a205341a9cf5b528ca3a02793a4927e2e6b3ddfd73e7698c3df4bad3a7bb4d37fc9fbb226c94c
-EBUILD fotowall-1.0.ebuild 1000 BLAKE2B 436e6e94b3165b48bfdaecfb8d6b05c8015a51769a8a1106586ec3beb3052d1a14ff3414670f6e9eb448c110329574199c0418f8475b88e15120dad084cdcd52 SHA512 e3a3d17f0aea859d72c7ede3b0605bfdaa864359a3536d37f9ed9da270fec253e815d111b8e5cb84b08f76906fb57053c0cfe7e64774c3d9ec8d5d8d13f8f13b
+EBUILD fotowall-1.0.ebuild 1039 BLAKE2B 2394a70ad4bf910e6551972a8f17e584931f62c1004dac270951f1715a61a013e66a0d126308eb7985abbe0fa88f8b892a15724bad51f56bc7c0492629e40ff8 SHA512 b1300687fb639ba2f6b2549016967a5f01d609a2d70294df29beb47d4880a3a13e78d7d0d3c409b17cb1001ccb010df701cddd95140567d09db3c93deed52f7f
MISC metadata.xml 396 BLAKE2B 0f50c7426ba992e6bf94bbc42cf99ea9f0daf7f4791d46cfea0ad57754692fa9e5d8462984a6357f4897e99b73553c248a1fa2f8048cccdc19083bce2d36c661 SHA512 538a67809974677e2c8f51b7ae7999047fffac2fa25677f0af5590afc061b5bd76f9908718bf8f66a6f9d4eaad4e4d2fa2e12837f5e15750035e879d79f93f59
diff --git a/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch b/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch
new file mode 100644
index 000000000000..db619771b476
--- /dev/null
+++ b/media-gfx/fotowall/files/fotowall-1.0-qt-5.11.patch
@@ -0,0 +1,28 @@
+Fix build with Qt 5.11.
+
+Bug: https://bugs.gentoo.org/661596
+
+--- a/App/tmp/CanvasAppliance.h
++++ b/App/CanvasAppliance.h
+@@ -17,6 +17,9 @@
+
+ #include "Shared/PlugGui/AbstractAppliance.h"
+ #include "ui_CanvasAppliance.h"
++
++#include <QActionGroup>
++
+ class QMenu;
+ class AbstractContent;
+ class Canvas;
+
+--- a/3rdparty/likebackfrontend/LikeBackDialog.cpp
++++ b/3rdparty/likebackfrontend/LikeBackDialog.cpp
+@@ -37,6 +37,7 @@
+ #include "LikeBackDialog.h"
+
+ #include <QApplication>
++#include <QButtonGroup>
+ #include <QLocale>
+ #include <QMessageBox>
+ #include <QNetworkAccessManager>
+
diff --git a/media-gfx/fotowall/fotowall-1.0.ebuild b/media-gfx/fotowall/fotowall-1.0.ebuild
index c4b9af4bfab4..660c5442ca6f 100644
--- a/media-gfx/fotowall/fotowall-1.0.ebuild
+++ b/media-gfx/fotowall/fotowall-1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,6 +31,8 @@ DEPEND="${RDEPEND}
src_prepare() {
default
+ eapply "${FILESDIR}/${P}-qt-5.11.patch"
+
sed -i -e "s|linux/videodev.h|libv4l1-videodev.h|" \
3rdparty/videocapture/VideoDevice.h || die