summaryrefslogtreecommitdiff
path: root/media-gfx/fotocx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
commit5181ced3f3566a9610b85922b083c8f84f20d78f (patch)
treed7eb288527e8bc248dd17ff874995d8bffe06704 /media-gfx/fotocx
parent7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (diff)
gentoo auto-resync : 08:05:2024 - 00:00:57
Diffstat (limited to 'media-gfx/fotocx')
-rw-r--r--media-gfx/fotocx/Manifest2
-rw-r--r--media-gfx/fotocx/fotocx-24.30.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/fotocx/Manifest b/media-gfx/fotocx/Manifest
index b42a370acadb..618b212626bc 100644
--- a/media-gfx/fotocx/Manifest
+++ b/media-gfx/fotocx/Manifest
@@ -1,4 +1,6 @@
AUX fotocx-24.20-documentation.patch 1373 BLAKE2B ac442711ae3eea89f1fa7a272004a0eda1857f4b4fd2f4045d794093bcfb81c16702039b578bef9768e9af503a126cabb62ed91bda384f64a4765efa73666f26 SHA512 17090677f4f726d6b0d5f2c14b76963e9090dffcd3773b02f66e6a87a6c7f9afe6f2c7060f2e375fb37a191c1846287b37f482f8efa78a84c2d381a50fcda751
DIST fotocx-24.21-source.tar.gz 16618357 BLAKE2B 43029d080cc843a03475b474c0807e0f2192bc6c64d20c5d41e90218f0b1f88db48aefb7622e8b521f06792a57a9d685d9c57107a309becc39d710ff5aa720a3 SHA512 2945fbaab800a115a1e0c718019ee1e66816cadf794a01db4f8238e7ba74ea033b6e9f24b4e42fe8105242f6df8861de7b00d32e81aae73577f5aa7f38c07f7f
+DIST fotocx-24.30-source.tar.gz 16103870 BLAKE2B 3261b9f4fb0345b37b146e443216e21d57ab9b11a1b77be9b9d94247cc8ae74442b75219fbf3d12f67ba16cee0cf772d3ba83d9e2b5ae38ddbbfd5bd42ea9c52 SHA512 39a4c8526e8fe7e49f4c85953e843243577b9a5b34b89030c452336f51c0ca6e381c38ba60ee39e6ee58b528d824240a821487e5e95a04dd44dabfe38e43f131
EBUILD fotocx-24.21-r1.ebuild 2288 BLAKE2B ab74c6ef40f963dc17b665783e0bfb9b72db4d2d2aa3aedd3d9c11f01cbd6c9bc06edbfdb7e7b060b4a2e9967ef6cf500e568ee0b13f0e77ab4b772d550ec075 SHA512 e4908a812733f629ee52d4116e9784205517992fb18f419e5eb8013614f8ce054ba36f190117c48b0114d658d93c634556ed3b0ab98d28394bc165ee2b23ba0b
+EBUILD fotocx-24.30.ebuild 2290 BLAKE2B ac644a95e6ef44d930373708544b28a9d75b00358c3e77be36bfaac5e8140f86a3815778e39efce0cb0676bda2d0bfb3d0a3edf8d58494c0f4391dee155e251a SHA512 bfa7e82236c754371ff92bdfa4db7804bb685b26bee97852d38c6be8b3f43e95ecb1f925ca30629470bebeaf0aa9e0eafee54975cefab45aadce7371621f998a
MISC metadata.xml 851 BLAKE2B a6c60b79fb5646c3bd7d6959d4a1b974ee714bf6ed64f205d9c00d684b3da94672005658336c1c5fcb903605d11c9a5607616151b2f6262f3173e15b8fc44655 SHA512 2794ae92afa076875c7f725969efdcf9cb84435d0ea033adc28f5860a69438b754f4d22b0db27dc7392683439e51b51ae581a6da450719276e8df51a2a306ad9
diff --git a/media-gfx/fotocx/fotocx-24.30.ebuild b/media-gfx/fotocx/fotocx-24.30.ebuild
new file mode 100644
index 000000000000..8eee122865a7
--- /dev/null
+++ b/media-gfx/fotocx/fotocx-24.30.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotocx/fotocx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}-source.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libchamplain[gtk]
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+PATCHES=( "${FILESDIR}/${PN}-24.20-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ sed -i -e "/^Icon/ s/\.png$//" ${PN}.desktop || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC & AVIF file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotocx/data/userguide and after running fotocx a copy will"
+ elog "be placed at /home/<user>/.fotocx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}