summaryrefslogtreecommitdiff
path: root/media-gfx/flameshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /media-gfx/flameshot
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'media-gfx/flameshot')
-rw-r--r--media-gfx/flameshot/Manifest4
-rw-r--r--media-gfx/flameshot/files/flameshot-0.6.0-unbundle-qtsingleapplication.patch47
-rw-r--r--media-gfx/flameshot/flameshot-0.6.0.ebuild53
-rw-r--r--media-gfx/flameshot/metadata.xml12
4 files changed, 116 insertions, 0 deletions
diff --git a/media-gfx/flameshot/Manifest b/media-gfx/flameshot/Manifest
new file mode 100644
index 000000000000..888b1c655386
--- /dev/null
+++ b/media-gfx/flameshot/Manifest
@@ -0,0 +1,4 @@
+AUX flameshot-0.6.0-unbundle-qtsingleapplication.patch 1505 BLAKE2B 51b8c59945f580d7777d4f9aeb954196bbd7e473301153053d451e0e07f08abb50a21fb993f940ab6ab40bfbbc6a14e04852d8e6a54e7ce4047ab64feb8cc2b5 SHA512 7543862bdead4f58435be97d09e4045ec1a9e77f90947c55076510da891627e189dc052cbd4ec8947203d5fa2c985220c2cd3fbb6cb9470222b3f5d42c61cf14
+DIST flameshot-0.6.0.tar.gz 641561 BLAKE2B f9e87373d84c1a841f70cd9c13b504865a0ef23d0fb29848f2270171459afe9c6852e12c712ebdc7cf3cfc62214d7b7507b85cf21838d0ebed33bee1e39f4aad SHA512 194127032ab0f62a6ba2698688e11b2d4e6f0e04a282144f5fbb6c232eeebc71371af2d55abbb6e98b8649dee036e6f0a6ef55710e4321a60fd5ac6e453ab975
+EBUILD flameshot-0.6.0.ebuild 1044 BLAKE2B b54aeb9ea019849b743108c8b8b93b5934488be6e1aeee1d50d6159fef2a6984acec7a98d70fd701f9e29078f16b8ca6218bcd2e5088cfef2a470cc920ca69cc SHA512 c517237fd626e61262772f8b47893302b26d1b0f51d679d9ec656f9f1d02e1e441319e951f79aaccc7816ceb2207e5f270a4019501b44ea47321a41149d86ac4
+MISC metadata.xml 366 BLAKE2B d8c8e83d8fb96199510eb45285312ca146aed73d76fd29ef52cd12cedd3b792621206b8ef064694ee60e12f73b932c6466051c85d0e1e2d8782aa2c00cb0bca4 SHA512 1bf8b212a62d64e14786dcf7ba6f97db414e04655fe0625d5ddc5b86d0e36f0c285f9722cdc1fedd39284e1331b167b947546c37b8a3a5441d59dcdf792a2506
diff --git a/media-gfx/flameshot/files/flameshot-0.6.0-unbundle-qtsingleapplication.patch b/media-gfx/flameshot/files/flameshot-0.6.0-unbundle-qtsingleapplication.patch
new file mode 100644
index 000000000000..7973aa1d06c8
--- /dev/null
+++ b/media-gfx/flameshot/files/flameshot-0.6.0-unbundle-qtsingleapplication.patch
@@ -0,0 +1,47 @@
+diff -ruN a/flameshot.pro b/flameshot.pro
+--- a/flameshot.pro 2020-05-25 21:16:54.044214597 +0300
++++ b/flameshot.pro 2020-05-25 21:25:03.808676488 +0300
+@@ -18,7 +18,7 @@
+ QT += dbus
+ }
+
+-CONFIG += c++11 link_pkgconfig
++CONFIG += c++11 link_pkgconfig qtsingleapplication
+
+ #CONFIG += packaging # Enables "make install" for packaging paths
+
+@@ -63,7 +63,6 @@
+
+ DEFINES += QT_DEPRECATED_WARNINGS
+
+-include(src/third-party/singleapplication/singleapplication.pri)
+ include(src/third-party/Qt-Color-Widgets//color_widgets.pri)
+
+ DEFINES += QAPPLICATION_CLASS=QApplication
+diff -ruN a/src/main.cpp b/src/main.cpp
+--- a/src/main.cpp 2020-05-25 21:16:54.055215952 +0300
++++ b/src/main.cpp 2020-05-25 21:25:35.095744395 +0300
+@@ -16,13 +16,13 @@
+ // along with Flameshot. If not, see <http://www.gnu.org/licenses/>.
+
+ #include "src/core/controller.h"
+-#include "singleapplication.h"
+ #include "src/utils/filenamehandler.h"
+ #include "src/utils/confighandler.h"
+ #include "src/cli/commandlineparser.h"
+ #include "src/utils/systemnotification.h"
+ #include "src/utils/pathinfo.h"
+ #include "src/core/capturerequest.h"
++#include <QtSingleApplication>
+ #include <QApplication>
+ #include <QTranslator>
+ #include <QTextStream>
+@@ -44,7 +44,7 @@
+
+ // no arguments, just launch Flameshot
+ if (argc == 1) {
+- SingleApplication app(argc, argv);
++ QtSingleApplication app(argc, argv);
+
+ QTranslator translator;
+ QStringList trPaths = PathInfo::translationsPaths();
diff --git a/media-gfx/flameshot/flameshot-0.6.0.ebuild b/media-gfx/flameshot/flameshot-0.6.0.ebuild
new file mode 100644
index 000000000000..e3d9daac1c78
--- /dev/null
+++ b/media-gfx/flameshot/flameshot-0.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg-utils
+
+DESCRIPTION="Powerful yet simple to use screenshot software"
+HOMEPAGE="https://flameshot.js.org"
+SRC_URI="https://github.com/lupoDharkael/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="FreeArt GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtwidgets:5
+ dev-qt/qtsvg:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtdbus:5
+ sys-apps/dbus
+"
+RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-unbundle-qtsingleapplication.patch" )
+
+src_prepare() {
+ rm -r src/third-party/singleapplication || die
+ default
+}
+
+src_configure() {
+ eqmake5 "CONFIG+=packaging"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
diff --git a/media-gfx/flameshot/metadata.xml b/media-gfx/flameshot/metadata.xml
new file mode 100644
index 000000000000..49f9e82790bb
--- /dev/null
+++ b/media-gfx/flameshot/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>paul.kalug@gmail.com</email>
+ <name>Pavel Kalugin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>