summaryrefslogtreecommitdiff
path: root/media-gfx/flam3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-gfx/flam3
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-gfx/flam3')
-rw-r--r--media-gfx/flam3/Manifest1
-rw-r--r--media-gfx/flam3/files/flam3-3.0.1-libpng15.patch76
2 files changed, 0 insertions, 77 deletions
diff --git a/media-gfx/flam3/Manifest b/media-gfx/flam3/Manifest
index aebde316cb4a..3acd6916bc13 100644
--- a/media-gfx/flam3/Manifest
+++ b/media-gfx/flam3/Manifest
@@ -1,4 +1,3 @@
-AUX flam3-3.0.1-libpng15.patch 2446 BLAKE2B 2fceeba5e87af7242e88cd9844aa6ccbd0e3aff989c9dcd3b3a22d65f3e3c28d9437d9ef48b46f74c1992d4575549a5238875d4e43d76865b7651e16df42f803 SHA512 e14120be47dbeef0d7790385f3202dee2014f6cc48631b6a14a3cc8b759771a32b4ef2a3cdfd5048d0286ef173c95d017b4c3c997bab3f909fb777a95832df28
DIST flam3-3.1.1.tar.gz 1181954 BLAKE2B 9691647704e96052f04f79b59b55b47285940ada3486ef6828d1e95934c5741915bf0e4f11c3ff39da7b5534b5c6c9ec16a88bc0568ac65c8a4b5d4aff9c8d29 SHA512 8a84840d9cb91d63dd0ba5c8a6725f703f6315a7add0c091502c0dac5c77eb0495054bb4b601f72454dea0def99131ca679095da65eeebaae9b01dc59cf75e7e
EBUILD flam3-3.1.1.ebuild 752 BLAKE2B a3610475d5b8ca2838ff1e63e8762f6abb33c81300eb1b347f808e1d9f73c883f91303130d6b7dccdb3f7cfe8ce12f7b3c22d41fcbb3262c27d970820e6c7fc3 SHA512 040bd665e40d14196122a32bdc39b60f9d120bdbf7c93e0b4134879fd1d57c6dd9ad0aac4b0c0ca5d4ef9090a54f93e3ba826eba1a3325aa75272fa5cfc518fd
MISC metadata.xml 322 BLAKE2B 8fa31c5e84e310169a863d1d66a77d73cff819cf595acfd7fc8f23c90a2271348899e8a5a5a5a184ea7de9428aebf7d841ab0a035fdc28f0ecd312396dcf3def SHA512 98b61c299f8cfa8c42a5f4b5b51b9eecbdffe3632ef8fd687afab26454fa8fccb71348a42cca69fbae7d154f69814feac61c4109ba671dd2fa413bf75e0445ca
diff --git a/media-gfx/flam3/files/flam3-3.0.1-libpng15.patch b/media-gfx/flam3/files/flam3-3.0.1-libpng15.patch
deleted file mode 100644
index 61f905589872..000000000000
--- a/media-gfx/flam3/files/flam3-3.0.1-libpng15.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-http://code.google.com/p/flam3/issues/detail?id=8
-
---- src/png.c
-+++ src/png.c
-@@ -142,7 +142,7 @@
- }
- if (setjmp(png_jmpbuf(png_ptr))) {
- if (png_image) {
-- for (y = 0 ; y < info_ptr->height ; y++)
-+ for (y = 0 ; y < png_get_image_height(png_ptr, info_ptr) ; y++)
- free (png_image[y]);
- free (png_image);
- }
-@@ -161,19 +161,19 @@
- png_set_sig_bytes (png_ptr, SIG_CHECK_SIZE);
- png_read_info (png_ptr, info_ptr);
-
-- if (8 != info_ptr->bit_depth) {
-+ if (8 != png_get_bit_depth(png_ptr, info_ptr)) {
- fprintf(stderr, "bit depth type must be 8, not %d.\n",
-- info_ptr->bit_depth);
-+ png_get_bit_depth(png_ptr, info_ptr));
- return 0;
- }
-
-- *width = info_ptr->width;
-- *height = info_ptr->height;
-+ *width = png_get_image_width(png_ptr, info_ptr);
-+ *height = png_get_image_height(png_ptr, info_ptr);
- p = q = malloc(4 * *width * *height);
-- png_image = (png_byte **)malloc (info_ptr->height * sizeof (png_byte*));
-+ png_image = (png_byte **)malloc (png_get_image_height(png_ptr, info_ptr) * sizeof (png_byte*));
-
-- linesize = info_ptr->width;
-- switch (info_ptr->color_type) {
-+ linesize = png_get_image_width(png_ptr, info_ptr);
-+ switch (png_get_color_type(png_ptr, info_ptr)) {
- case PNG_COLOR_TYPE_RGB:
- linesize *= 3;
- break;
-@@ -182,21 +182,21 @@
- break;
- default:
- fprintf(stderr, "color type must be RGB or RGBA not %d.\n",
-- info_ptr->color_type);
-+ png_get_color_type(png_ptr, info_ptr));
- return 0;
- }
-
-- for (y = 0 ; y < info_ptr->height ; y++) {
-+ for (y = 0 ; y < png_get_image_height(png_ptr, info_ptr) ; y++) {
- png_image[y] = malloc (linesize);
- }
- png_read_image (png_ptr, png_image);
- png_read_end (png_ptr, info_ptr);
-
-- for (y = 0 ; y < info_ptr->height ; y++) {
-+ for (y = 0 ; y < png_get_image_height(png_ptr, info_ptr) ; y++) {
- unsigned char *s = png_image[y];
-- for (x = 0 ; x < info_ptr->width ; x++) {
-+ for (x = 0 ; x < png_get_image_width(png_ptr, info_ptr) ; x++) {
-
-- switch (info_ptr->color_type) {
-+ switch (png_get_color_type(png_ptr, info_ptr)) {
- case PNG_COLOR_TYPE_RGB:
- p[0] = s[0];
- p[1] = s[1];
-@@ -217,7 +217,7 @@
- }
- }
-
-- for (y = 0 ; y < info_ptr->height ; y++)
-+ for (y = 0 ; y < png_get_image_height(png_ptr, info_ptr) ; y++)
- free (png_image[y]);
- free (png_image);
- png_destroy_read_struct (&png_ptr, &info_ptr, (png_infopp)NULL);