summaryrefslogtreecommitdiff
path: root/media-gfx/figurine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /media-gfx/figurine
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'media-gfx/figurine')
-rw-r--r--media-gfx/figurine/Manifest3
-rw-r--r--media-gfx/figurine/figurine-1.0.5-r1.ebuild18
-rw-r--r--media-gfx/figurine/files/figurine-1.0.5-fno-common.patch115
3 files changed, 125 insertions, 11 deletions
diff --git a/media-gfx/figurine/Manifest b/media-gfx/figurine/Manifest
index bbe11a8164e2..0ed2877f8faf 100644
--- a/media-gfx/figurine/Manifest
+++ b/media-gfx/figurine/Manifest
@@ -1,3 +1,4 @@
+AUX figurine-1.0.5-fno-common.patch 2566 BLAKE2B 0cebcee0c402b52164d9c0a376e5c199100d9201b1db7a4b16249780b886a610dbd7659a992a3e9ed1544fcbe6df8a0f01a0c84b16a75f3054b607840cdbc0b9 SHA512 75ec0d882534b001c04b210ad4488bd0caa442f55e3811cc25bbf10b2313a8859473d6d3e9c13f594a35f11d4b90b327254a6dd6642cfdfce9562b34058479aa
DIST figurine-1.0.5.tar.gz 293105 BLAKE2B 1530ee872cb80e4aa629ec4901c48b49a4aee77667286563da50c037a820ea028defb135e47c1b1b6363b7a59d55d633b30dc516f3b43819b3cc4e61439a6cba SHA512 e3b6a2d0d4b8a4837f27eb40ff158444ff59ac7d826cc780c6c13760e0d6e72844a7b6de69e482dfee12c020600e40c58fb5b4b9efa935342ada6fe62b57eff6
-EBUILD figurine-1.0.5-r1.ebuild 565 BLAKE2B 52a5baee14437c9097776c3d5ac581fbe4fd8f330212c6f9a8abe91316a72aefbd0de928b21f042116800fd7ca141ec50e18a0e940def7d290848a3c11d6b8fb SHA512 c74b9e752075b56be4d897553578519958f3b2fef7370b019e41b8eddd3da206eb3a3cd2c72245e52057927bdae46defe6b9aeeb8f2433d4815796042d2d3472
+EBUILD figurine-1.0.5-r1.ebuild 537 BLAKE2B c27bdf99c9fac399fad4a4c039389ff739f82dc7ad082b539c1692c27464a0bd561adcf015a594f02792fdd484c3e455a8c0f7b3b5babda3a7e21343247bc5cc SHA512 0b0588bf8789460200a860cf674b94080effa6baf4984553914e532fc52296873dfc2038712f0a36efa206c8c152ea251898c642ebc5ad2a84413feda4a924ad
MISC metadata.xml 245 BLAKE2B 0d2e3e7b0bbd5f0c960bf5de591a6729a33552e5e32a4f19f2b7ab79e849dad285bf7e8c88134f213d99d9c83cee8672b37250ed84ad6c6f480bab5fdab368f1 SHA512 122e29d489968047e70dd824a49ffc4dede2a4c632e203a820abe03ea2478cb94b7aad94409ca235f227a034e16141c556fbe462833edfa802f03169215d4c0d
diff --git a/media-gfx/figurine/figurine-1.0.5-r1.ebuild b/media-gfx/figurine/figurine-1.0.5-r1.ebuild
index 7c6fffe4dba9..1895738ddc54 100644
--- a/media-gfx/figurine/figurine-1.0.5-r1.ebuild
+++ b/media-gfx/figurine/figurine-1.0.5-r1.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="A vector based graphics editor similar to xfig, but simpler"
HOMEPAGE="http://figurine.sourceforge.net/"
@@ -10,17 +12,13 @@ SRC_URI="mirror://sourceforge/figurine/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=media-gfx/transfig-3.2"
+DEPEND="media-gfx/transfig"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_configure() {
+ tc-export CC
econf
}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README
-}
diff --git a/media-gfx/figurine/files/figurine-1.0.5-fno-common.patch b/media-gfx/figurine/files/figurine-1.0.5-fno-common.patch
new file mode 100644
index 000000000000..362d40b2257a
--- /dev/null
+++ b/media-gfx/figurine/files/figurine-1.0.5-fno-common.patch
@@ -0,0 +1,115 @@
+https://bugs.gentoo.org/707666
+--- a/src/draw.c
++++ b/src/draw.c
+@@ -126,6 +126,8 @@
+ #include "include/figurine.h"
+ #include "include/extern.h"
+
++extern GC whitegc;
++
+ /* redraws a section of a view */
+ /* this should really take a number of disjoint regions */
+ void
+--- a/src/include/extern.h
++++ b/src/include/extern.h
+@@ -285,7 +285,7 @@ extern Pixmap bfills[];
+ extern Pixmap nofill;
+ extern char *filltags[];
+ extern char *fontnames[40][2];
+-int numfontnames;
++extern int numfontnames;
+ extern List afonts;
+
+ extern uint justificationicon_number;
+--- a/src/include/stk_extern.h
++++ b/src/include/stk_extern.h
+@@ -71,8 +71,8 @@ extern GC fontgc;
+ extern GC sfontgc;
+ extern GC colgc;
+ extern Cursor stk_arrow_cursor;
+-XFontStruct *stk_font;
+-XFontStruct *stk_sfont;
++extern XFontStruct *stk_font;
++extern XFontStruct *stk_sfont;
+ extern List stk_window_list;
+ extern stkInternalMenuBar stk_menu_bar;
+ extern stkInternalIconPanel stk_icon_panel;
+--- a/src/init.c
++++ b/src/init.c
+@@ -151,6 +151,8 @@
+ /* xbm's for fillstyle */
+ #include "pixmaps/fillstyles.h"
+
++extern int numfontnames;
++extern GC whitegc;
+
+ static Colormap colourmap;
+ static Visual *visual;
+--- a/src/stk_dialog.c
++++ b/src/stk_dialog.c
+@@ -74,6 +74,9 @@
+
+ static int dial_ticket=0;
+
++extern XFontStruct *stk_sfont;
++extern GC whitegc;
++
+ void free_list(void *);
+ void set_window_cursor(Window, int);
+
+--- a/src/stk_globals.c
++++ b/src/stk_globals.c
+@@ -52,7 +52,7 @@
+ #include "include/stk.h"
+
+ GC topleftgc; /* top & left decoration */
+-GC whitegc; /* white */
++extern GC whitegc; /* white */
+ GC bottomrightgc; /* bottom and right decoration */
+ GC backgroundgc; /* standard GC for STK widget */
+ GC fontgc; /* for drawing the font */
+--- a/src/stk_init.c
++++ b/src/stk_init.c
+@@ -60,6 +60,9 @@
+ extern int screen;
+ extern WindowStruct bar_window;
+
++extern XFontStruct *stk_sfont;
++extern GC whitegc;
++
+ void free_list(void *);
+
+ void
+--- a/src/stk_keyboard.c
++++ b/src/stk_keyboard.c
+@@ -59,6 +59,8 @@
+
+ int str_print(char *str);
+
++extern XFontStruct *stk_font;
++
+ int str_print(char *str)
+ {
+ while (*str!='\0')
+--- a/src/stk_menu.c
++++ b/src/stk_menu.c
+@@ -85,6 +85,8 @@
+
+ void free_list(void *);
+
++extern XFontStruct *stk_font;
++
+ /* create top-level menu bar */
+ int
+ stk_create_menu_bar(WindowStruct window, stkMenuBar *menu)
+--- a/src/stk_util.c
++++ b/src/stk_util.c
+@@ -70,6 +70,8 @@
+
+ extern Atom windelete;
+
++extern XFontStruct *stk_font;
++
+ /* client-side toggle tooltips */
+ void
+ stk_tooltips(Boolean on)