summaryrefslogtreecommitdiff
path: root/media-gfx/farbfeld/farbfeld-3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/farbfeld/farbfeld-3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/farbfeld/farbfeld-3.ebuild')
-rw-r--r--media-gfx/farbfeld/farbfeld-3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/farbfeld/farbfeld-3.ebuild b/media-gfx/farbfeld/farbfeld-3.ebuild
new file mode 100644
index 000000000000..b8bab18a1e31
--- /dev/null
+++ b/media-gfx/farbfeld/farbfeld-3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="farbfeld simple image format tools"
+HOMEPAGE="https://tools.suckless.org/farbfeld/"
+SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-libs/libjpeg-turbo
+ media-libs/libpng:*
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3-as-needed.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC/d' \
+ -e 's|/usr/local|/usr|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall -Wextra $(INCS) $(CPPFLAGS)|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
+ -e 's|{|(|g;s|}|)|g' \
+ config.mk || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install MANPREFIX=/usr/share/man
+}