summaryrefslogtreecommitdiff
path: root/media-gfx/exiv2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
commit490ef2c2dc8b4e808f37add1adee21a754efd9a9 (patch)
treee235cdf15550b3d2f644b6fc4a8aa726971416f5 /media-gfx/exiv2
parentda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (diff)
gentoo auto-resync : 21:04:2024 - 12:05:28
Diffstat (limited to 'media-gfx/exiv2')
-rw-r--r--media-gfx/exiv2/Manifest1
-rw-r--r--media-gfx/exiv2/exiv2-0.28.2-r1.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index a19a44ab3c14..add6a9149a35 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1,4 +1,5 @@
AUX exiv2-0.28.2-errors-localisation.patch 835 BLAKE2B af7821671a1f852d3169eb1577814f390e5943165fff73ea568906e71253a381c72ebe5b3fc623668a7d37f6bfd988e7eff3b505e04f0fb8f6f95b3a8398cc20 SHA512 d228eed586b257e992566d1ebb655753a7bec6ce6ab56773dc7feeb93fa479b4f98a1db4ac64e95eed2447ed27ee434eed40d9c4a230be6fe6f8788fa9d5ed7f
DIST exiv2-0.28.2.tar.gz 45224206 BLAKE2B 9d1d05c99804032dfb9b740e543d1e3cceae011b17853c8565ccad87e726ce1d0f410c13bf4fa8839bc8e0fecdf170a3acac568f14aad4628b3b844f6c21dd7e SHA512 197cc607c0271b5731714713283756250031cef81ba7ed5d9c3e222b4c2397966cc2bbdbceaae706598329dde6f8a9729597d0ae4c36ac264c76546942e4e37b
+EBUILD exiv2-0.28.2-r1.ebuild 3332 BLAKE2B f8ba9b05ca6b487a4cf06a1da0bcc1432f220fc85a9285aec874d99308ce13ea266b8e86a0fb41eb1820a2faa24bccbb21650a91c39a9e4c2cfc769592d03b02 SHA512 1c94f2171ec2139e411610dcd7e92d565ff774b01d6640e19be586cd42031210395c4ddbc3d345b1d2caf3935b7332226b2cec05309b8ba1392ab5a81b3fecdd
EBUILD exiv2-0.28.2.ebuild 3258 BLAKE2B d9838ddc51a1ddfb73589d54fe00c87325bdba61c5efb589a931b805869dcaeb8cf10b6b3a484a812326d00f3d63c8771869ab617693c9dfdd4a6be4492aa94b SHA512 85e35f969b4689acde0eb85a7bce891fdb08d97c6de95f5d65d5649635ce17b089a3ccad31639fc6edc0caeac7d7ba2d13b592e23efbbba5b92f323edfdbbff9
MISC metadata.xml 686 BLAKE2B 2d1079660cf4268216f8835d1ae6655ebafc99d5402872bb05dac6342034a28a07dcff587fc616a5eedc8c538ea3e43e013711d39c2541295e89629e39a244ee SHA512 40f9225a42386fa6f03bf9436d675bb01bd6eb859974bfed22d1316536ceaf40752fabffdab20b439e87c57f65d193d8d249e5aa022584de3f869f4162660b4e
diff --git a/media-gfx/exiv2/exiv2-0.28.2-r1.ebuild b/media-gfx/exiv2/exiv2-0.28.2-r1.ebuild
new file mode 100644
index 000000000000..f9cb7f722f63
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.28.2-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
+HOMEPAGE="https://exiv2.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Exiv2/exiv2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+fi
+
+LICENSE="GPL-2"
+# Upstream hope to have stable ABI in 1.0. Until then, go off ${PV}.
+# We may be able to change it to $(ver_cut 1-2) once e.g.
+# https://github.com/Exiv2/exiv2/pull/917 is merged.
+SLOT="0/$(ver_cut 1-2)"
+IUSE="+bmff doc examples jpegxl nls +png test webready +xmp"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/inih[${MULTILIB_USEDEP}]
+ >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ jpegxl? ( app-arch/brotli:=[${MULTILIB_USEDEP}] )
+ nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
+ png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ webready? ( net-misc/curl[${MULTILIB_USEDEP}] )
+ xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="
+ doc? (
+ ${PYTHON_DEPS}
+ app-text/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz
+ virtual/pkgconfig
+ )
+ test? ( ${PYTHON_DEPS} )
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( README.md doc/ChangeLog doc/cmd.txt )
+
+PATCHES=( "${FILESDIR}/${P}-errors-localisation.patch" )
+
+pkg_setup() {
+ if use doc || use test ; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # FIXME @upstream:
+ einfo "Converting doc/cmd.txt to UTF-8"
+ iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
+ mv -f doc/cmd.txt.tmp doc/cmd.txt || die
+
+ cmake_src_prepare
+
+ sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DEXIV2_BUILD_SAMPLES=NO
+ -DEXIV2_ENABLE_BROTLI=$(usex jpegxl)
+ -DEXIV2_ENABLE_NLS=$(usex nls)
+ -DEXIV2_ENABLE_PNG=$(usex png)
+ -DEXIV2_ENABLE_CURL=$(usex webready)
+ -DEXIV2_ENABLE_INIH=ON # must be enabled (bug #921937)
+ -DEXIV2_ENABLE_WEBREADY=$(usex webready)
+ -DEXIV2_ENABLE_XMP=$(usex xmp)
+ -DEXIV2_ENABLE_BMFF=$(usex bmff)
+
+ # We let users control this.
+ -DBUILD_WITH_CCACHE=OFF
+ # Our toolchain sets this by default.
+ -DBUILD_WITH_STACK_PROTECTOR=OFF
+
+ $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
+ $(multilib_is_native_abi && echo -DEXIV2_BUILD_UNIT_TESTS=$(usex test))
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ if use doc || use test ; then
+ mycmakeargs+=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && eninja doc
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ cd "${BUILD_DIR}"/bin || die
+ ./unit_tests || die "Failed to run tests"
+ fi
+}
+
+multilib_src_install_all() {
+ use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
+
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc samples/*.cpp
+ fi
+}