summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /media-gfx/eog-plugins
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest2
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.26.3.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index fd71cced0338..1cbb3deedf6b 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,5 @@
DIST eog-plugins-3.16.6.tar.xz 398836 BLAKE2B fcd3c6dc61ca6d935580caffdf9c941d34265f8caa6cd3d682e0d7679888f6965f64ac30b807c00417e904b4e0eeff1a213a8f6d284c130abe265f9c97fc636b SHA512 e3bff786785ae36a41bc7c5fcb3cf75233595777409f373c4a6597fa6e432f72c7a75608e09ab66e1033ca0d12e3855346d7f7e0c571014b5aaef40184a3383b
+DIST eog-plugins-3.26.3.tar.xz 470712 BLAKE2B cd5845481006b681555f35d1f353ed624baa83fc8fc45bb889b2418f31a776bf9e08e270f911f61f431123825a5b96fa684f72e378ddd0ad1107ff44a5c98519 SHA512 5ea0bbf692fa71fa77b0b78307cceee067c95e80c2e69e173990c1154df8014912f24f8d023eda79da56b7c1bdf0870e5e92b968a68c4961af3fc1382d4f468c
EBUILD eog-plugins-3.16.6-r1.ebuild 1603 BLAKE2B f260b6b3e7f3f2710b5875bede7448dda4e717205d4abc03ff4f8d102cb3c3e6ad3d1d85108f2382f8b2aea984de910228b2b150c1cd7f9b9483264b3124c8d0 SHA512 46bbf6a0236ce8957d28beb82414c6c3bb6b7e7ae0411f1cf295e0aca0bc5296448076e1aec09f0d970217556fcbe0bdee635741db81f6eb4ef4d2423bf9cf51
+EBUILD eog-plugins-3.26.3.ebuild 1652 BLAKE2B 5c0cf60a96213a7e486362c5b7fa78d36617f6cc6b9bcdad2b1896a890ebd0fc70b8e2c4aeb94b87e187e7ca91317a08c7c96718ffca0c70ec0f26f1d329c11b SHA512 7e1631b5cbfc22acb3524ac3f3c4105d91d104aa28fa77d3bfc8930ccd24cdc23853b3edf2323438459cbd2537929248536c64de8b41d148a41d7902d4531e10
MISC metadata.xml 428 BLAKE2B b10706bb7638538d5ce63c9787e7a1730e01c8383f2d2a093e38184b031933d2b3749241aa2f3254be4c84fac104bb8ec72940cdf8cd5a9f7bc0944541b015c6 SHA512 9684f07846ce7e49ad82843c2b8b7ac5c9d7124bddb07778292d6810162e89a3d41e7ca426f331e4bae6ecfbe53f71409b35418affba6382e874c78b64ed102f
diff --git a/media-gfx/eog-plugins/eog-plugins-3.26.3.ebuild b/media-gfx/eog-plugins/eog-plugins-3.26.3.ebuild
new file mode 100644
index 000000000000..93902b0bb3c4
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.26.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}