summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 06:33:49 +0000
commit78634f348a30a55cc55606ee1ecde032241ceaeb (patch)
tree528e39df571e37b31bfca1811c69bcc06c4af22f /media-gfx/eog-plugins
parent434fbe89e81a1fe06d92676be72ab7f862cc3f53 (diff)
gentoo auto-resync : 19:03:2023 - 06:33:49
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest2
-rw-r--r--media-gfx/eog-plugins/eog-plugins-44.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index dc50f54a8fd8..9b322669e63a 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,5 @@
DIST eog-plugins-42.3.tar.xz 134284 BLAKE2B 903ee1af89d48c46ab12d1330b4605cd78db573d59d5fc6ba34c27a8b017ce90c2af0b55009e5ecec61229dbdd8852bc4ecc5b10e6a2d2391c06e8244f7b24da SHA512 af680fe7cc83d3b3ae6782127edf90cf2a89093030f15d22fe5ff81eb165a493dc487b32a41383c36b72ce188c8f49b3f52ca3b991d24faa9667b0317bff414f
+DIST eog-plugins-44.0.tar.xz 134544 BLAKE2B db384d949f2a63cb0fcdf1bdfb8ed4c5c97af88d21079af5de7560b3c3bab231a6361ae459727a9b9f31b49e63f7cd227f465a1a7b8e2bc55e8d7a08f0335ed9 SHA512 2955830aa60a3518869ec1af7a9f0c455277b0a571cb14a5e5926b52b80ed0443e91f28e270feffcf26066e1e9b6080c9a457b55175051c20838c8b80e2da195
EBUILD eog-plugins-42.3.ebuild 1789 BLAKE2B 1149b7fea1b066da0e515b47f6ff1d1b97a659c1c52573d83a1bb3f48bd0cd348acaf96c68859573d0606f113f84c7828471ba4a80d31ee1e04de3297d8ad8fb SHA512 1bd3e4cd02d4fd1424ee05450a55b5322b1bd6f3112d81be4d68d5c88ae1be3fbd6f37f8181464825561ede86913ec3ea3f24a7f0fbc87b58e05f21df375abc1
+EBUILD eog-plugins-44.0.ebuild 1791 BLAKE2B a73a744b43885eb5b499cd8f58893511738fb64302a197db5bba9af607c4cf1c7c162d23929e8404f6ee6b481117d8af45b42335d7b0dc0fb1e89d7d1d9d3018 SHA512 2dbdc7d5cce87e190a3935c4719f4b1986e9c90c8c1c784eda9f81945347c9d9430bf2221729245bdf204769134682f6efa7e23bbeb9115d03cd34a2fe93bacc
MISC metadata.xml 541 BLAKE2B ee4eb7e0faf9345c05620ca09bcd761ef02bd5d5b38485b6fa17cfb52f5b602dac9f598876de728e8a9d9e223f28e6a73afa34b8bcbccb376c41785a53f252f2 SHA512 46ffc768901c97363eb9cbbf3ec1b06b0ccfe8ce99be944866d4459383c0778a151f94437f16254b8955742d4c2f863fb63dc34cf49368e7fb49da8aa788612b
diff --git a/media-gfx/eog-plugins/eog-plugins-44.0.ebuild b/media-gfx/eog-plugins/eog-plugins-44.0.ebuild
new file mode 100644
index 000000000000..1a40b2451460
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-44.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins https://gitlab.gnome.org/GNOME/eog-plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1
+ >=media-gfx/eog-41.0:1
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/appstream-glib )"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ $(meson_use picasa plugin_postasa)
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}