summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 17:32:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 17:32:06 +0100
commit7138219e3c9446bf981ff17f5609f42130bec414 (patch)
treeb898b17778ed104dd89b2980386bae53594b001d /media-gfx/eog-plugins
parent1afe1c223c048ca2c33fa230c83d620c04fecb8f (diff)
gentoo auto-resync : 24:09:2022 - 17:32:06
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest3
-rw-r--r--media-gfx/eog-plugins/eog-plugins-42.2.ebuild78
-rw-r--r--media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch79
3 files changed, 160 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index f13e3f3e0e3e..f537de4c3b99 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,6 @@
+AUX 42.2-build-Use-correct-variables.patch 2235 BLAKE2B 712eeea244e080961cc81cfbf13fe534f1360593832f46c6249952d0509d9aba4ee2b42eab2fab77803d943740bbe6661b09f2394247dfc06e167f9c3e9c3bba SHA512 d45b9e373ba9c73cf9cf6bd83bc05e36bc6d37471cf18b7041b443842e5d6de942dff50eb7a73939533cede2263291cf142f22052b1d89166b45daa82ab8731f
DIST eog-plugins-42.1.tar.xz 131656 BLAKE2B e561e7b31daf950c1e1c1e1038bf40101b658583160439f7fd9050b52da2f6dd943105e1e1eeaefff7ed2aa759f8b96aad0a65130daba038733967db37158bfc SHA512 4688cb9cce044137717521a3ff2f769f960f12ec8b3f711971f276334f91915c8a3142aff2feb3d24d2eeb86223f040e9b699a1136e7fc7e96202a06b1cda1a8
+DIST eog-plugins-42.2.tar.xz 131708 BLAKE2B 7df06ca7d4d10e068b6d758ec3c29fe8cb7a2037755bab55536f1cd3581790f7a1288a9530f256df3d2adbf6d7f8c893907fa962be8adb77510cab8e9684298c SHA512 7508231c1a6b365acfedd73b37911d5ac4194e6b5c4f5d80be27529ec749774d61ddc75288f8678d879f0cc2d9117a5f725092efe30403b5b3e145c77fa3030d
EBUILD eog-plugins-42.1.ebuild 1722 BLAKE2B b3f1e17ee4b098b2ac63a70d3cdc3f7caaf2db9d647d289ddf4e2f81b91283d917a12a1f47569deecca1c8be054ce67bb660ba36f750ca07d82c5089e1122bf2 SHA512 4d3265072000f00915e49967c2f4297c6513697d1dbd3e686ab5a09f0e5aa821fd38a684bceb8d3ea3458a9f7004957c3f7c1a41a5158defe38c2f9c4cb7e6ca
+EBUILD eog-plugins-42.2.ebuild 1859 BLAKE2B e2001d07b29c0a7f6256ca4879cb8aac774dcdb60836af82cebb9b6135a24b74f2bd719d460b2c141c76b6b9f6a7091bf9b5f9257b9b8ae9c4f25be97d2b5074 SHA512 86742b13198d8ebe83124b423cd5243fb4573759b57282aa28f470177701aeeecd53ac26551b1a2fcd1fabb829529997c76853749611c31df9d3d1e193cf1647
MISC metadata.xml 429 BLAKE2B 61e0c5a268c0dbcb1a2b0a0e1d0ceb1b7795db34e022ba9229015ecf05210dcdd247c2c9867549f5c75028dcb20011f7757fd9b4ef507af65b80aa8aa1ca6f18 SHA512 d4b81d9f78bf49afe842990d9c1c9dde1c3f1bc68090f77dde1bd51b2be98ab647be10f8886da7dcc1831cabc4f7c81b18b7e6e5cadb2c5aeeec69db883509bf
diff --git a/media-gfx/eog-plugins/eog-plugins-42.2.ebuild b/media-gfx/eog-plugins/eog-plugins-42.2.ebuild
new file mode 100644
index 000000000000..7bbd98c06f65
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-42.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins https://gitlab.gnome.org/GNOME/eog-plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:=
+ >=media-gfx/eog-41.0
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/appstream-glib )"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-build-Use-correct-variables.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ $(meson_use picasa plugin_postasa)
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}
diff --git a/media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch b/media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch
new file mode 100644
index 000000000000..5bf08c190392
--- /dev/null
+++ b/media-gfx/eog-plugins/files/42.2-build-Use-correct-variables.patch
@@ -0,0 +1,79 @@
+https://gitlab.gnome.org/GNOME/eog-plugins/-/merge_requests/8
+
+From 00d734931a911e072c22b60028f361ee3f6cad14 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sat, 24 Sep 2022 11:25:25 -0400
+Subject: [PATCH] build: Use correct variables
+
+Bug: https://bugs.gentoo.org/858089
+---
+ plugins/fit-to-width/meson.build | 2 +-
+ plugins/light-theme/meson.build | 2 +-
+ plugins/map/meson.build | 4 ++--
+ plugins/send-by-mail/meson.build | 2 +-
+ 4 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/plugins/fit-to-width/meson.build b/plugins/fit-to-width/meson.build
+index 37732d1..e9654c0 100644
+--- a/plugins/fit-to-width/meson.build
++++ b/plugins/fit-to-width/meson.build
+@@ -46,7 +46,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ fittowidth_appdata.full_path(),
+ ]
+ )
+ endif
+diff --git a/plugins/light-theme/meson.build b/plugins/light-theme/meson.build
+index 044b08a..fb86cdc 100644
+--- a/plugins/light-theme/meson.build
++++ b/plugins/light-theme/meson.build
+@@ -46,7 +46,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ lighttheme_appdata.full_path(),
+ ]
+ )
+ endif
+diff --git a/plugins/map/meson.build b/plugins/map/meson.build
+index d969e96..c8f5c41 100644
+--- a/plugins/map/meson.build
++++ b/plugins/map/meson.build
+@@ -36,7 +36,7 @@ i18n.merge_file(
+ install_dir: pluginlibdir,
+ )
+
+-exifdisplay_appdata = i18n.merge_file(
++map_appdata = i18n.merge_file(
+ input: 'eog-map.appdata.xml.in',
+ output: '@BASENAME@',
+ po_dir: src_root / 'po',
+@@ -52,7 +52,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ map_appdata.full_path(),
+ ]
+ )
+ endif
+diff --git a/plugins/send-by-mail/meson.build b/plugins/send-by-mail/meson.build
+index f7eb0fb..7bba7a1 100644
+--- a/plugins/send-by-mail/meson.build
++++ b/plugins/send-by-mail/meson.build
+@@ -47,7 +47,7 @@ if appstream_util.found()
+ args: [
+ 'validate',
+ '--nonet',
+- exifdisplay_appdata.full_path(),
++ sendbymail_appdata.full_path(),
+ ]
+ )
+ endif
+--
+2.35.1
+