summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-gfx/eog-plugins
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest2
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.26.5.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 00e15b24a983..7de89b73a449 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,5 @@
DIST eog-plugins-3.26.4.tar.xz 477772 BLAKE2B 104ddf58d33e5513349839312fef820af20d7a3e64a3a8cbd7d964d8250564d6cd62c58cf95fb5359ab95eac8fe2b83ed051e6f3dc8144a8884ec72c74a12622 SHA512 95f2cf2c6ed84b4801517a708f18e1cd673f814d849029a41491f3719512d6a3a2cb5cb11898a7f972f8b674c682245c99964ba2da19b285ed175b720d5396e8
+DIST eog-plugins-3.26.5.tar.xz 478188 BLAKE2B 655eb9860435775862ba44bd26530edff778a3c8c574e9bf592800b4d57b4e5b0e52d36b7d71d6a6d615d47c320542105dcee9de89250901fcbfa6c255dcfddc SHA512 3b7979d241c2c0b522ffb6c30a6b8c90fed9e899cda8a73fb9d9a9392f474516f8c24fc75f3f35f920c8a6cf04b8bda611a8669839588936c48467813a6227a7
EBUILD eog-plugins-3.26.4-r1.ebuild 1688 BLAKE2B a8facd636930691003351dc4f962970dcc19509ef2df7f106899ade4caeade426e2e5223856c7ea8f6a9decc80861d12bebfaa66b1ab164a03d016150b492c05 SHA512 86920010db0205fa3aa896a18b371acb4c72c0a277aed032675eff40cbe87b7985847c7bdddb007b5575072e50732da650e68bad315c6724c9d3cb53ba753eae
+EBUILD eog-plugins-3.26.5.ebuild 1690 BLAKE2B 44cad63aad7db7c197dbca6f8950179f66cded046c54ec12cd2c8cb27044a4ad7f5e05ac4cf3bc6ec298201331c2d9d381206e9b771f091094319041edfcf500 SHA512 206fcee5d41e6117b0f5708311aaeb24fb5e5e09e2345cb78efead1c676e9fc39c55b8f86ee07aa6a6cc5715c1c5950c038f9b529c2b59ffb77ee0fd9071b033
MISC metadata.xml 428 BLAKE2B b10706bb7638538d5ce63c9787e7a1730e01c8383f2d2a093e38184b031933d2b3749241aa2f3254be4c84fac104bb8ec72940cdf8cd5a9f7bc0944541b015c6 SHA512 9684f07846ce7e49ad82843c2b8b7ac5c9d7124bddb07778292d6810162e89a3d41e7ca426f331e4bae6ecfbe53f71409b35418affba6382e874c78b64ed102f
diff --git a/media-gfx/eog-plugins/eog-plugins-3.26.5.ebuild b/media-gfx/eog-plugins/eog-plugins-3.26.5.ebuild
new file mode 100644
index 000000000000..897a10d8bda6
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.26.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}