summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /media-gfx/eog-plugins
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest2
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 7cce006dccea..e70fbb24d907 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,5 @@
DIST eog-plugins-3.26.7.tar.xz 482336 BLAKE2B 9cd1d7e16f8e7f1fe06c3bc2ea79ab06c397beaf9d9bfb26568ad5fb90a144ceab11f6250c7dd51ebb5d3962fff47a4c855b85725b95abca07cdc4de739a2b7e SHA512 c9312eccc5529b01cb285a165c833243ea60bb12f8be6f40ccc6da0db1bd951916000a48aa31705b048659e8d637aa7e56d761fe0f9be720a4e0ce81289d2b83
+DIST eog-plugins-3.26.8.tar.xz 479356 BLAKE2B ab781311473e045ffbb88e741427ac59f129fa53e6c551231d7b6edae81d21483dd1f1e7874561dfa29c9e9b2ba01fbdb174302bf8363478b785ec2ce38c53ec SHA512 a58aa849b09761dd0c7f7d31098560969872b03788f3f3ee81445dfb9be653b29e0e6646abc4e0164e4146abf7a9d2e6aadf56071f71c119493dcf1fd706a069
EBUILD eog-plugins-3.26.7.ebuild 1725 BLAKE2B 5063f5a3c9e9e9a55749b6df79a1b1dba448e071c517b8eac94dcea955db715f1c4ae979dd49b9c2e549c0b5ca85d6b86fa351936259e399efc3930105a48ac8 SHA512 b4ff645c5af1295765cd2f92bd44ed3fc5a188693e14e2237cd16f6a838940d3e9bc60e6b07e77818296a0ead6c8c0b102f798695c3b4d0092c24e2c7572972a
+EBUILD eog-plugins-3.26.8.ebuild 1727 BLAKE2B d11bdef0fbced2c5a08cc07e4aa37d4d8d175c381e887e9b661b30f49f1acec9c06db8bff60c5ff2c3b345006a77284ca0dbfd5a62915390e7999c09a8d536fd SHA512 8ef59b185005fbbe54c22b3265ff2c76bfe47c03882b14889e9a0dab051d159281f7148ca38f0826cb5421e9bf894cabf32d938cd1815c62a9e71f8689a90661
MISC metadata.xml 429 BLAKE2B 61e0c5a268c0dbcb1a2b0a0e1d0ceb1b7795db34e022ba9229015ecf05210dcdd247c2c9867549f5c75028dcb20011f7757fd9b4ef507af65b80aa8aa1ca6f18 SHA512 d4b81d9f78bf49afe842990d9c1c9dde1c3f1bc68090f77dde1bd51b2be98ab647be10f8886da7dcc1831cabc4f7c81b18b7e6e5cadb2c5aeeec69db883509bf
diff --git a/media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild b/media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild
new file mode 100644
index 000000000000..bb6d66aaee22
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.26.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ default
+ mv "${ED}"/usr/share/{appdata,metainfo}
+ find "${ED}" -type f -name "*.la" -delete || die
+}