summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /media-gfx/eog-plugins
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest1
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.16.6-r1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 9963649441f5..42675382c334 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,4 @@
DIST eog-plugins-3.16.6.tar.xz 398836 BLAKE2B fcd3c6dc61ca6d935580caffdf9c941d34265f8caa6cd3d682e0d7679888f6965f64ac30b807c00417e904b4e0eeff1a213a8f6d284c130abe265f9c97fc636b SHA512 e3bff786785ae36a41bc7c5fcb3cf75233595777409f373c4a6597fa6e432f72c7a75608e09ab66e1033ca0d12e3855346d7f7e0c571014b5aaef40184a3383b
+EBUILD eog-plugins-3.16.6-r1.ebuild 1605 BLAKE2B ff82bab6762937e92faac33664f81b3708f9bbb2ab76de3e72c0f8c50cf4c65d6c45b7d239931601d47da6b2f306a5b6ba51f5cbf050c5441e3f15b041220cde SHA512 f399df08431b798eef407b7aedfc5731a7378701878b730a89c2494969c34d7204be7842dadd1361ff2fdc2baffb57d6ceb3534b4e3e010bab2b91bf4e78b2a7
EBUILD eog-plugins-3.16.6.ebuild 1681 BLAKE2B bcda004d6f20ba29826c3637f718cdff0ee1895ce0d79dcf743285d9dd7023772580c3f05eea82871c77c2260d16f8c91b01c5a10ceff8b91ccee60f8c9f7b08 SHA512 2b3137f6b4cceee79c705db382f620e203fc7d5625662b8ec5eb1c92c349d3fa85c1bf7dbf428bd5b327af94dc614f44094e15318e0a987f3e332866c902fcf1
MISC metadata.xml 483 BLAKE2B fc83eeea54c41053a3857d37d763caa1642ae1074bd759f1a01bf85952825289bfeae5ad0c8b63ca0aa58e78b5bfaa2b29c90de393a912fc7aecafb76cf9a726 SHA512 f1b4c8e14547335019aa74506f2c5391783cabe118aa91e8f658117a6151cd53bb1728d36ae63a5c50fe9d548ee6f6b47294ae0c0af43e869de9815cf600afed
diff --git a/media-gfx/eog-plugins/eog-plugins-3.16.6-r1.ebuild b/media-gfx/eog-plugins/eog-plugins-3.16.6-r1.ebuild
new file mode 100644
index 000000000000..a0b0057c5589
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-3.16.6-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libpeas-0.7.4:=
+ >=media-gfx/eog-3.15.90
+ >=x11-libs/gtk+-3.14:3
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0 )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.32:2[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local plugins="fit-to-width,send-by-mail,hide-titlebar,light-theme"
+ use exif && plugins="${plugins},exif-display"
+ use map && plugins="${plugins},map"
+ use picasa && plugins="${plugins},postasa"
+ use python && plugins="${plugins},slideshowshuffle,pythonconsole,fullscreenbg,export-to-folder,maximize-windows"
+ gnome2_src_configure \
+ $(use_enable python) \
+ --with-plugins=${plugins}
+}