summaryrefslogtreecommitdiff
path: root/media-gfx/dpic/dpic-20200901.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /media-gfx/dpic/dpic-20200901.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'media-gfx/dpic/dpic-20200901.ebuild')
-rw-r--r--media-gfx/dpic/dpic-20200901.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/dpic/dpic-20200901.ebuild b/media-gfx/dpic/dpic-20200901.ebuild
new file mode 100644
index 000000000000..eb96fbf0dae4
--- /dev/null
+++ b/media-gfx/dpic/dpic-20200901.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Converts PIC plots into pstricks, PGF/TikZ, PostScript, MetaPost and TeX"
+HOMEPAGE="https://ece.uwaterloo.ca/~aplevich/dpic"
+SRC_URI="https://ece.uwaterloo.ca/~aplevich/dpic/${PN}-2020.09.01.tar.gz"
+
+# dpic: BSD-2, dpicdoc.pdf: CC-BY-3.0, p2c: GPL
+LICENSE="BSD-2 CC-BY-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+S="${WORKDIR}/${PN}-2020.09.01"
+
+src_install() {
+ dobin dpic
+ doman doc/dpic.1
+
+ einstalldocs
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}