summaryrefslogtreecommitdiff
path: root/media-gfx/displaycal-py3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 20:21:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 20:21:39 +0000
commitdd03974882f85ca04e35cfbc97f7ff756f5d5c20 (patch)
tree4fabcc91c51083e19657dd0a557043e74468106e /media-gfx/displaycal-py3
parentd542bd2ef95af892c7ef62be1489b0288b1df9e3 (diff)
gentoo auto-resync : 20:02:2023 - 20:21:39
Diffstat (limited to 'media-gfx/displaycal-py3')
-rw-r--r--media-gfx/displaycal-py3/Manifest3
-rw-r--r--media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild66
-rw-r--r--media-gfx/displaycal-py3/metadata.xml17
3 files changed, 86 insertions, 0 deletions
diff --git a/media-gfx/displaycal-py3/Manifest b/media-gfx/displaycal-py3/Manifest
new file mode 100644
index 000000000000..dbeaf6d8d7be
--- /dev/null
+++ b/media-gfx/displaycal-py3/Manifest
@@ -0,0 +1,3 @@
+DIST DisplayCAL-3.9.10.tar.gz 10676033 BLAKE2B 94bfa3ac95bfc16788421fa5b9a31920c40da66d2875e4037b3b20b6792a1005ee9fea11b5325a94ffae845f56583647e42de9d4d7d96d149264a86e6d1158a6 SHA512 fc1b981925c6f4660557d8f0935a62d0112b39664b0c74cdb1a907e0e7b7e3f61ec76986fa2072f8ada1d105ebfa61bb116df75dc10f902ff545db3368634fc5
+EBUILD displaycal-py3-3.9.10.ebuild 1494 BLAKE2B 9696773d870850429eea8df9d7c62624277f2c0ba2475271c367e5b642124a70c2c5dea38d5916eb0cad8ec028089c76a31c8fb21aa68f2042e76d203b03217f SHA512 c82759379322f0d177365081a7fcc61eb7d258e3e60e149345290c33cd6a054f6586911a1fdbf302b282a1a4eeeb447fcc660a299e71d8a83a2c313832d62af5
+MISC metadata.xml 790 BLAKE2B aa3f32f061f4840bbc0e29c36e6154cc37b85a9fa76a92e7f69a32ccadef16fa5a9680266c35b51c3351c4f4d65e2e1659515550e2366c9c9516e8c26c049694 SHA512 d4fad45e53ac19ede7f26709878ff36b55906a4c642b1ce7ce2e49ef56a1285582700d07170f702263a3a99ea0bfa2c2cfbc842978f565291d3322fb9a6a5c0d
diff --git a/media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild b/media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild
new file mode 100644
index 000000000000..0aef7b5146ef
--- /dev/null
+++ b/media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+SRC_URI="https://github.com/eoyilmaz/displaycal-py3/releases/download/${PV}/${MY_P}.tar.gz"
+KEYWORDS="~amd64"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Modernize the DisplayCAL code including Python 3 support"
+HOMEPAGE="https://github.com/eoyilmaz/displaycal-py3"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/certifi:0[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pychromecast[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/zeroconf[${PYTHON_USEDEP}]
+ >=dev-python/wxpython-4.2.0[${PYTHON_USEDEP}]
+ media-gfx/argyllcms
+ x11-libs/libXxf86vm"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix QA warning
+ sed -e 's/license_file/license_files/g' -i setup.cfg || die
+
+ # Remove x-world MIME
+ sed -i 's|x-world/x-vrml;||g' \
+ misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Use Gentoo package name for doc folder
+ mv "${ED}/usr/share/doc/${MY_P}" "${ED}/usr/share/doc/${P}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/media-gfx/displaycal-py3/metadata.xml b/media-gfx/displaycal-py3/metadata.xml
new file mode 100644
index 000000000000..6ee5175df506
--- /dev/null
+++ b/media-gfx/displaycal-py3/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sarnex@gentoo.org</email>
+ <name>Nick Sarnie</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eoyilmaz/displaycal-py3</remote-id>
+ </upstream>
+ <longdescription>
+ This project intended to modernize the DisplayCAL code including Python 3 support.
+ Florian Höch, the original developer, did an incredible job of creating and maintaining DisplayCAL for all these years.
+ But, it seems that, during the pandemic, very understandably, he lost his passion to the project.
+ Now, it is time for us, the DisplayCAL community, to contribute back to this great tool.
+ </longdescription>
+</pkgmetadata>