summaryrefslogtreecommitdiff
path: root/media-gfx/darktable/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /media-gfx/darktable/files
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'media-gfx/darktable/files')
-rw-r--r--media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch26
-rw-r--r--media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch28
-rw-r--r--media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch19
3 files changed, 73 insertions, 0 deletions
diff --git a/media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch b/media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch
new file mode 100644
index 000000000000..8ad4f0e9329f
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.0.2_cmake-march-autodetection.patch
@@ -0,0 +1,26 @@
+Darktable and RawSpeed upstream support two build modes: if BINARY_PACKAGE_BUILD==1
+they pass -mtune=generic to the compiler, otherwise they use -march=native.
+In either case, these options override externally set CFLAGS.
+
+Disable this behaviour so that the users' settings provided to the ebuild by Portage
+are respected.
+
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -521,7 +521,7 @@
+ set(DT_REQ_INSTRUCTIONS "-msse2")
+ endif()
+
+- include(march-mtune)
++ set(MARCH "")
+
+ #if(NOT BUILD_SSE2_CODEPATHS)
+ # set(MARCH "${MARCH} -mno-sse2 -D__DISABLE_SSE2__ -U__SSE2__ -D__DISABLE_SSE__ -U__SSE__")
+--- a/src/external/rawspeed/cmake/compiler-flags.cmake
++++ b/src/external/rawspeed/cmake/compiler-flags.cmake
+@@ -1,5 +1,4 @@
+ include(CheckCXXCompilerFlag)
+-include(CpuMarch)
+ include(CheckCXXCompilerFlagAndEnableIt)
+
+ # yes, need to keep both the CMAKE_CXX_FLAGS and CMAKE_CXX_STANDARD.
diff --git a/media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch b/media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch
new file mode 100644
index 000000000000..c1fd701fb9a4
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.0.2_cmake-opencl-kernel-loop.patch
@@ -0,0 +1,28 @@
+From 767d48e0f60e7f858e8b31a88dd8cc1258e7ee9e Mon Sep 17 00:00:00 2001
+From: Marcus Haehnel <marcus@mh-development.info>
+Date: Sat, 21 Mar 2020 09:14:45 +0100
+Subject: [PATCH] Fix invalid CMake syntax
+
+The syntax of the foreach statement in data/kernels/CMakeLists.txt
+was invalid. This lead to errors when running cmake.
+
+Use correct syntax to make the build work.
+---
+ data/kernels/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/data/kernels/CMakeLists.txt b/data/kernels/CMakeLists.txt
+index ce947bef9c..f605c18b7e 100644
+--- a/data/kernels/CMakeLists.txt
++++ b/data/kernels/CMakeLists.txt
+@@ -31,8 +31,8 @@ macro (testcompile_opencl_kernel IN)
+ endmacro (testcompile_opencl_kernel)
+
+ if (TESTBUILD_OPENCL_PROGRAMS)
+- foreach(IN ${DT_OPENCL_KERNELS})
+- testcompile_opencl_kernel(${IN})
++ foreach(KERNEL IN ITEMS ${DT_OPENCL_KERNELS})
++ testcompile_opencl_kernel(${KERNEL})
+ endforeach()
+ endif()
+
diff --git a/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch b/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch
new file mode 100644
index 000000000000..1aa0aec5163f
--- /dev/null
+++ b/media-gfx/darktable/files/darktable-3.0.2_jsonschema-automagic.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -319,15 +319,7 @@
+ message(STATUS "Test-compilation of OpenCL programs is disabled.")
+ endif()
+
+-# we need jsonschema to check noiseprofiles.json
+-find_program(jsonschema_BIN jsonschema)
+-if(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+- message(STATUS "Missing jsonschema, problems in noiseprofiles.json might go unnoticed")
+- set(VALIDATE_JSON 0)
+-else(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
+- message(STATUS "Found jsonschema")
+- set(VALIDATE_JSON 1)
+-endif(${jsonschema_BIN} STREQUAL "jsonschema_BIN-NOTFOUND")
++set(VALIDATE_JSON 0)
+
+ # we need an xslt interpreter to generate preferences_gen.h and darktablerc
+ find_program(Xsltproc_BIN xsltproc)