summaryrefslogtreecommitdiff
path: root/media-gfx/darktable/darktable-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /media-gfx/darktable/darktable-9999.ebuild
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'media-gfx/darktable/darktable-9999.ebuild')
-rw-r--r--media-gfx/darktable/darktable-9999.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/media-gfx/darktable/darktable-9999.ebuild b/media-gfx/darktable/darktable-9999.ebuild
index 0a707bfeba93..ffbe61010f4d 100644
--- a/media-gfx/darktable/darktable-9999.ebuild
+++ b/media-gfx/darktable/darktable-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils flag-o-matic toolchain-funcs gnome2-utils fdo-mime git-r3 pax-utils eutils versionator
+inherit cmake-utils flag-o-matic toolchain-funcs gnome2-utils xdg-utils git-r3 pax-utils eutils versionator
EGIT_REPO_URI="https://github.com/darktable-org/${PN}.git"
@@ -15,7 +15,7 @@ SLOT="0"
#KEYWORDS="~amd64 ~x86"
LANGS=" ca cs da de es fr he hu it ja nl pl ru sk sl sv uk"
# TODO add lua once dev-lang/lua-5.2 is unmasked
-IUSE="colord cups cpu_flags_x86_sse3 doc flickr geo gphoto2 graphicsmagick jpeg2k kwallet libsecret
+IUSE="colord cups cpu_flags_x86_sse3 doc flickr geolocation gnome-keyring gphoto2 graphicsmagick jpeg2k kwallet
nls opencl openmp openexr pax_kernel webp
${LANGS// / l10n_}"
@@ -35,20 +35,19 @@ CDEPEND="
media-libs/tiff:0
net-libs/libsoup:2.4
net-misc/curl
+ sys-libs/zlib:=
virtual/jpeg:0
- virtual/glu
- virtual/opengl
x11-libs/cairo
>=x11-libs/gtk+-3.14:3
x11-libs/pango
colord? ( x11-libs/colord-gtk:0= )
cups? ( net-print/cups )
flickr? ( media-libs/flickcurl )
- geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ geolocation? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ gnome-keyring? ( >=app-crypt/libsecret-0.18 )
gphoto2? ( media-libs/libgphoto2:= )
graphicsmagick? ( media-gfx/graphicsmagick )
- jpeg2k? ( media-libs/openjpeg:0 )
- libsecret? ( >=app-crypt/libsecret-0.18 )
+ jpeg2k? ( media-libs/openjpeg:2= )
opencl? ( virtual/opencl )
openexr? ( media-libs/openexr:0= )
webp? ( media-libs/libwebp:0= )"
@@ -57,7 +56,11 @@ RDEPEND="${CDEPEND}
DEPEND="${CDEPEND}
dev-util/intltool
virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ opencl? (
+ >=sys-devel/clang-4
+ >=sys-devel/llvm-4
+ )"
pkg_pretend() {
if use openmp ; then
@@ -81,9 +84,9 @@ src_configure() {
-DUSE_FLICKR=$(usex flickr)
-DUSE_GRAPHICSMAGICK=$(usex graphicsmagick)
-DUSE_KWALLET=$(usex kwallet)
- -DUSE_LIBSECRET=$(usex libsecret)
+ -DUSE_LIBSECRET=$(usex gnome-keyring)
-DUSE_LUA=OFF
- -DUSE_MAP=$(usex geo)
+ -DUSE_MAP=$(usex geolocation)
-DUSE_NLS=$(usex nls)
-DUSE_OPENCL=$(usex opencl)
-DUSE_OPENEXR=$(usex openexr)
@@ -91,11 +94,13 @@ src_configure() {
-DUSE_OPENMP=$(usex openmp)
-DUSE_WEBP=$(usex webp)
)
+ CMAKE_BUILD_TYPE="RELWITHDEBINFO"
cmake-utils_src_configure
}
src_install() {
cmake-utils_src_install
+ use doc && dodoc "${DISTDIR}"/${PN}-usermanual-${DOC_PV}.pdf
for lang in ${LANGS} ; do
use l10n_${lang} || rm -r "${ED}"/usr/share/locale/${lang/-/_}
@@ -117,10 +122,10 @@ pkg_preinst() {
pkg_postinst() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}
pkg_postrm() {
gnome2_icon_cache_update
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}