summaryrefslogtreecommitdiff
path: root/media-gfx/chafa/chafa-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /media-gfx/chafa/chafa-1.6.0.ebuild
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'media-gfx/chafa/chafa-1.6.0.ebuild')
-rw-r--r--media-gfx/chafa/chafa-1.6.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/chafa/chafa-1.6.0.ebuild b/media-gfx/chafa/chafa-1.6.0.ebuild
new file mode 100644
index 000000000000..2c7e6798a528
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+ tools? ( >=media-libs/freetype-2.0.0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-man \
+ $(use_with tools)
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}" -name '*.la' -delete || die
+}