summaryrefslogtreecommitdiff
path: root/media-gfx/blender/blender-2.79b-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /media-gfx/blender/blender-2.79b-r1.ebuild
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'media-gfx/blender/blender-2.79b-r1.ebuild')
-rw-r--r--media-gfx/blender/blender-2.79b-r1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/media-gfx/blender/blender-2.79b-r1.ebuild b/media-gfx/blender/blender-2.79b-r1.ebuild
index 9add67424fe1..147bcd56b0d9 100644
--- a/media-gfx/blender/blender-2.79b-r1.ebuild
+++ b/media-gfx/blender/blender-2.79b-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
PYTHON_COMPAT=( python{3_5,3_6} )
-inherit check-reqs cmake-utils xdg-utils flag-o-matic gnome2-utils \
+inherit check-reqs cmake-utils xdg-utils flag-o-matic xdg-utils \
pax-utils python-single-r1 toolchain-funcs eapi7-ver
DESCRIPTION="3D Creation/Animation/Publishing System"
@@ -20,7 +20,7 @@ MY_PV="$(ver_cut 1-2)"
SLOT="0"
LICENSE="|| ( GPL-2 BL )"
KEYWORDS="amd64 ~x86"
-IUSE="+bullet +dds +elbeem +game-engine +openexr collada colorio \
+IUSE="+bullet +dds +elbeem +game-engine +openexr collada color-management \
cuda cycles debug doc ffmpeg fftw headless jack jemalloc jpeg2k libav \
llvm man ndof nls openal opencl openimageio openmp opensubdiv openvdb \
osl player sdl sndfile test tiff valgrind"
@@ -47,7 +47,7 @@ RDEPEND="${PYTHON_DEPS}
virtual/libintl
virtual/opengl
collada? ( >=media-libs/opencollada-1.6.18:= )
- colorio? ( media-libs/opencolorio )
+ color-management? ( media-libs/opencolorio )
cuda? ( dev-util/nvidia-cuda-toolkit:= )
ffmpeg? ( media-video/ffmpeg:=[x264,mp3,encode,theora,jpeg2k?] )
libav? ( >=media-video/libav-11.3:=[x264,mp3,encode,theora,jpeg2k?] )
@@ -180,7 +180,7 @@ src_configure() {
-DWITH_MOD_OCEANSIM=$(usex fftw)
-DWITH_OPENAL=$(usex openal)
-DWITH_OPENCL=$(usex opencl)
- -DWITH_OPENCOLORIO=$(usex colorio)
+ -DWITH_OPENCOLORIO=$(usex color-management)
-DWITH_OPENCOLLADA=$(usex collada)
-DWITH_OPENIMAGEIO=$(usex openimageio)
-DWITH_OPENMP=$(usex openmp)
@@ -256,10 +256,6 @@ src_install() {
python_optimize "${ED%/}/usr/share/blender/${MY_PV}/scripts"
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
elog
elog "Blender uses python integration. As such, may have some"
@@ -277,12 +273,12 @@ pkg_postinst() {
ewarn "If you are concerned about security, file a bug upstream:"
ewarn " https://developer.blender.org/"
ewarn
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_mimeinfo_database_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_mimeinfo_database_update
ewarn ""