summaryrefslogtreecommitdiff
path: root/media-gfx/apngasm/apngasm-2.91.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/apngasm/apngasm-2.91.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/apngasm/apngasm-2.91.ebuild')
-rw-r--r--media-gfx/apngasm/apngasm-2.91.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/apngasm/apngasm-2.91.ebuild b/media-gfx/apngasm/apngasm-2.91.ebuild
new file mode 100644
index 000000000000..e5d8debea7bf
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.91.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="https://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="ZLIB 7z? ( LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="7z zopfli"
+
+RDEPEND="media-libs/libpng:0=[apng]
+ sys-libs/zlib
+ zopfli? ( app-arch/zopfli:= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_prepare() {
+ default
+
+ # remove bundled libs
+ rm -r zopfli zlib libpng || die
+
+ if use 7z; then
+ append-cflags -DFEATURE_7ZIP
+ else
+ sed -i '/^SRC_DIRS\s\+=/s/7z//' Makefile || die
+ fi
+
+ if use zopfli; then
+ append-cflags -DFEATURE_ZOPFLI
+ sed -i '/^LIBS\s\+=/s/$/ -lzopfli/' Makefile || die
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}