summaryrefslogtreecommitdiff
path: root/media-gfx/alembic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 11:38:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 11:38:54 +0100
commit9d8d34d0eedfd7319f905092519980bf1b4ce3e5 (patch)
tree75f96ca3abc9e54aeb3960716b735719c2447b6a /media-gfx/alembic
parentd6260e76da0a436affc6839e470dd8619841cadc (diff)
gentoo auto-resync : 11:04:2023 - 11:38:54
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/Manifest3
-rw-r--r--media-gfx/alembic/alembic-1.8.5.ebuild72
-rw-r--r--media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch48
3 files changed, 123 insertions, 0 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 12b2fffc0456..e013b8df9566 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1,4 +1,7 @@
AUX alembic-1.8.0-0001-set-correct-libdir.patch 1879 BLAKE2B 2cbcdfee02094745544ebc67e467e452d225a8a9445481f984eaadf399544bfac24a410d8a7f4137f4b73d038e7f5eaf08ea492aa7bb95f15fede87fef081eb6 SHA512 d1ec399048a6baebdbd4eadb5be55281693455d0280dd3ff86d8747d2aaf52eede4c6848d71362e17de2d23d063357ff983bb3a8ecad28e81303f72a76f48a02
+AUX alembic-1.8.5-set-correct-libdir.patch 1593 BLAKE2B 4dec05376ed35261049886e38c851ded8f033040e5fe822337ec7655132f0b24b007e6b48caf9fb01cfc3a874a4a60b0f54649e3505f70464c1847423c684176 SHA512 befd7956ab3effb70d76648c15795cf8ea40d51687dab3988968a519267bdf1df945d475f1cd7a32747d6a5fd6cf1cf63c8f0bbbc058e9da704ba26b6bac443a
DIST alembic-1.8.4.tar.gz 867788 BLAKE2B b7bc5ebcaebc5905a9a2e45be21170a72923fd6af6d9f97b81bdc7e8b80bb037ed3f667ea15a5b96194b33687010fda455e4df8355f92fc29aa000beae32cae8 SHA512 2473f4b9afe3fddbd2d0477bdc85d93697e413410253a7f7f0f030fba919dfb63dabd2d2d13829f59f3f901643ab842d230a9f08fb667e2c16cef0e751a8a687
+DIST alembic-1.8.5.tar.gz 867976 BLAKE2B 715ff6212ab78b2b4d3f5ea3b448468ade488008a8362193b4976671a69ad89337f926082c7736e64a0b07bf71e04d774df5e22abe409f8cfab1a15ccb3c86bb SHA512 89a480970eb09893112bf650011ede852205d1fa3718680a3983392bbcf3eb3f22f4ec01f42d12bfcaf655ce43d7d6f583b764ec03f4c5a84023359502b3636e
EBUILD alembic-1.8.4.ebuild 1546 BLAKE2B a659e953e8e583f47fe7666bb07402711529a6bb73882b7adc774a23ebe0dcab37e2acebd91e6045edbdad20019eecb5a2d4cc45c5ef4f471a62df1e0c496313 SHA512 1d02598f85e6b27877c559bbf9f617857e49cf1775118226033f064c9ed2613e3403d776e26a5ef82858b4397f1f16cc2a5b1072c881e4d0793a3c05168f3c12
+EBUILD alembic-1.8.5.ebuild 1775 BLAKE2B 891e3dfb5b4b67d9c1dcc43e94ba1fe6171c72807768922e7ab5c38120345bf89e0a8fb6469047400bf6b9c50d54e04882b90703e6b4bbb4f5c088806335fcea SHA512 8d0a039b9891f038fab1891e318c4e9cee0b34097674ac54d50eba9d06b2c218e123e82d8c243b6e937a467bfcda481e4ac4179302667748a9d7a014095791cf
MISC metadata.xml 824 BLAKE2B 55b10435d032292b05af14bde6a69772eaf7993bd1686a0f1489313624d14b3572037d6ba7e9caab7bb69ed36cb61d5f1518d6c945e9e7c3853dcde1e80e3e0d SHA512 55c878337d8297cd8d811443d8821835e4ee5096364014bc43c798a34645076dc47ec405bdfd3c62a03481f8539cca9fadd8f7f15a2bb98471c9f7d0d57450a1
diff --git a/media-gfx/alembic/alembic-1.8.5.ebuild b/media-gfx/alembic/alembic-1.8.5.ebuild
new file mode 100644
index 000000000000..e69f73e9d37e
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.8.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="examples hdf5 python test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ examples? ( python )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/imath:=
+ python? ( dev-libs/imath:=[python,${PYTHON_SINGLE_USEDEP}] )
+ hdf5? (
+ >=sci-libs/hdf5-1.10.2:=[zlib(+)]
+ >=sys-libs/zlib-1.2.11-r1
+ )
+ python? ( $(python_gen_cond_dep 'dev-libs/boost[python,${PYTHON_USEDEP}]') )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.5-set-correct-libdir.patch )
+
+DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
+
+src_prepare() {
+ cmake_src_prepare
+ # Tests are broken with python 3.11. See also: https://github.com/alembic/alembic/issues/411
+ cmake_run_in "${S}/python/PyAlembic" cmake_comment_add_subdirectory Tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_BUILD_LIBS=ON
+ -DALEMBIC_DEBUG_WARNINGS_AS_ERRORS=OFF
+ -DALEMBIC_SHARED_LIBS=ON
+ # currently does nothing but require doxygen
+ -DDOCS_PATH=OFF
+ -DUSE_ARNOLD=OFF
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=OFF
+ -DUSE_PRMAN=OFF
+ -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_TESTS=$(usex test)
+ )
+
+ use python && mycmakeargs+=( -DPython3_EXECUTABLE=${PYTHON} )
+
+ cmake_src_configure
+}
+
+# some tests may fail if run in parallel mode
+# see https://github.com/alembic/alembic/issues/401
+src_test() {
+ cmake_src_test -j1
+}
diff --git a/media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch b/media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch
new file mode 100644
index 000000000000..70071a68e49b
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch
@@ -0,0 +1,48 @@
+From fade0b08f9343fa3cd941b281a3ce49a1918acca Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 18 Mar 2023 19:08:51 +0100
+Subject: [PATCH] Gentoo-specific: set correct libdir
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,12 +74,12 @@ option(DOCS_PATH
+
+ # Set static/dynamic build options
+ SET(LIB_TYPE STATIC)
+-SET(RUNTIME_INSTALL_DIR lib)
+-SET(LIBRARY_INSTALL_DIR lib)
+-SET(ARCHIVE_INSTALL_DIR lib)
++SET(RUNTIME_INSTALL_DIR lib${LIB_SUFFIX})
++SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
++SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (ALEMBIC_SHARED_LIBS)
+ SET(LIB_TYPE SHARED)
+- SET(ARCHIVE_INSTALL_DIR lib)
++ SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (WIN32)
+ ADD_DEFINITIONS(-DALEMBIC_DLL)
+ ENDIF()
+--- a/lib/Alembic/CMakeLists.txt
++++ b/lib/Alembic/CMakeLists.txt
+@@ -84,7 +84,7 @@ TARGET_LINK_LIBRARIES(Alembic
+ ${ZLIB_LIBRARY}
+ )
+
+-SET( ALEMBIC_LIB_INSTALL_DIR lib CACHE STRING "Where to install the Alembic libs")
++SET( ALEMBIC_LIB_INSTALL_DIR lib${LIB_SUFFIX} CACHE STRING "Where to install the Alembic libs")
+ INSTALL(TARGETS Alembic
+ EXPORT AlembicTargets
+ LIBRARY DESTINATION ${ALEMBIC_LIB_INSTALL_DIR}
+@@ -97,7 +97,7 @@ INSTALL(TARGETS Alembic
+
+ set(alembic_targets_file "${PROJECT_NAME}Targets.cmake")
+
+-SET(ConfigPackageLocation lib/cmake/Alembic CACHE PATH
++SET(ConfigPackageLocation lib${LIB_SUFFIX}/cmake/Alembic CACHE PATH
+ "Where to install the Alembic's cmake files")
+
+ INCLUDE(CMakePackageConfigHelpers)
+--
+2.40.0
+