summaryrefslogtreecommitdiff
path: root/media-gfx/alembic/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /media-gfx/alembic/files
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'media-gfx/alembic/files')
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch189
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch13
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch30
-rw-r--r--media-gfx/alembic/files/alembic-1.7.9-prman.patch26
4 files changed, 258 insertions, 0 deletions
diff --git a/media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch b/media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch
new file mode 100644
index 000000000000..06ebf60b0d67
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-CMakeLists-fix_lib.patch
@@ -0,0 +1,189 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 298f4be..18b3ff5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -80,12 +80,12 @@ OPTION(ALEMBIC_LIB_USES_TR1
+
+ # Set static/dynamic build options
+ SET(LIB_TYPE STATIC)
+-SET(RUNTIME_INSTALL_DIR lib)
+-SET(LIBRARY_INSTALL_DIR lib)
+-SET(ARCHIVE_INSTALL_DIR lib)
++SET(RUNTIME_INSTALL_DIR lib${LIB_SUFFIX})
++SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
++SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (ALEMBIC_SHARED_LIBS)
+ SET(LIB_TYPE SHARED)
+- SET(ARCHIVE_INSTALL_DIR lib)
++ SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (WIN32)
+ ADD_DEFINITIONS(-DALEMBIC_DLL)
+ ENDIF()
+diff --git a/arnold/Procedural/CMakeLists.txt b/arnold/Procedural/CMakeLists.txt
+index 69e00da..47ccf66 100644
+--- a/arnold/Procedural/CMakeLists.txt
++++ b/arnold/Procedural/CMakeLists.txt
+@@ -60,7 +60,7 @@ TARGET_LINK_LIBRARIES( AlembicArnoldProcedural Alembic::Alembic)
+
+ set_target_properties(AlembicArnoldProcedural PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL ( TARGETS
+ AlembicArnoldProcedural
+diff --git a/bin/AbcConvert/CMakeLists.txt b/bin/AbcConvert/CMakeLists.txt
+index 451409c..c882971 100644
+--- a/bin/AbcConvert/CMakeLists.txt
++++ b/bin/AbcConvert/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcconvert Alembic::Alembic)
+
+ set_target_properties(abcconvert PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcconvert DESTINATION bin)
+diff --git a/bin/AbcDiff/CMakeLists.txt b/bin/AbcDiff/CMakeLists.txt
+index 511864a..bed92b2 100644
+--- a/bin/AbcDiff/CMakeLists.txt
++++ b/bin/AbcDiff/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcdiff Alembic::Alembic)
+
+ set_target_properties(abcdiff PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcdiff DESTINATION bin)
+diff --git a/bin/AbcEcho/CMakeLists.txt b/bin/AbcEcho/CMakeLists.txt
+index be5f5c1..eca449a 100644
+--- a/bin/AbcEcho/CMakeLists.txt
++++ b/bin/AbcEcho/CMakeLists.txt
+@@ -41,6 +41,6 @@ TARGET_LINK_LIBRARIES(abcechobounds Alembic::Alembic)
+
+ set_target_properties(abcecho abcechobounds PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcecho abcechobounds DESTINATION bin)
+diff --git a/bin/AbcLs/CMakeLists.txt b/bin/AbcLs/CMakeLists.txt
+index 815f84f..92f83c4 100644
+--- a/bin/AbcLs/CMakeLists.txt
++++ b/bin/AbcLs/CMakeLists.txt
+@@ -39,6 +39,6 @@ TARGET_LINK_LIBRARIES(abcls Alembic::Alembic)
+
+ set_target_properties(abcls PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcls DESTINATION bin)
+diff --git a/bin/AbcStitcher/CMakeLists.txt b/bin/AbcStitcher/CMakeLists.txt
+index a963420..a84e00b 100644
+--- a/bin/AbcStitcher/CMakeLists.txt
++++ b/bin/AbcStitcher/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abcstitcher Alembic::Alembic)
+
+ set_target_properties(abcstitcher PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abcstitcher DESTINATION bin)
+diff --git a/bin/AbcTree/CMakeLists.txt b/bin/AbcTree/CMakeLists.txt
+index b4f65f1..74225ac 100644
+--- a/bin/AbcTree/CMakeLists.txt
++++ b/bin/AbcTree/CMakeLists.txt
+@@ -38,6 +38,6 @@ TARGET_LINK_LIBRARIES(abctree Alembic::Alembic)
+
+ set_target_properties(abctree PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS abctree DESTINATION bin)
+diff --git a/lib/Alembic/CMakeLists.txt b/lib/Alembic/CMakeLists.txt
+index fb3def8..d5bbcec 100644
+--- a/lib/Alembic/CMakeLists.txt
++++ b/lib/Alembic/CMakeLists.txt
+@@ -84,7 +84,7 @@ IF ( ${ALEMBIC_LIB_USES_TR1} AND CMAKE_COMPILER_IS_GNUCXX AND
+ TARGET_LINK_LIBRARIES( Alembic atomic )
+ ENDIF()
+
+-SET( ALEMBIC_LIB_INSTALL_DIR lib CACHE PATH "Where to install the Alembic libs")
++SET( ALEMBIC_LIB_INSTALL_DIR lib${LIB_SUFFIX} CACHE PATH "Where to install the Alembic libs")
+ INSTALL(TARGETS Alembic
+ EXPORT AlembicTargets
+ LIBRARY DESTINATION ${ALEMBIC_LIB_INSTALL_DIR}
+@@ -117,7 +117,7 @@ EXPORT(TARGETS
+ Alembic::
+ )
+
+-SET(ConfigPackageLocation lib/cmake/Alembic CACHE PATH
++SET(ConfigPackageLocation lib${LIB_SUFFIX}/cmake/Alembic CACHE PATH
+ "Where to install the Alembic's cmake files")
+
+ INSTALL(FILES
+diff --git a/maya/AbcExport/CMakeLists.txt b/maya/AbcExport/CMakeLists.txt
+index 50d2fd2..f8bc850 100644
+--- a/maya/AbcExport/CMakeLists.txt
++++ b/maya/AbcExport/CMakeLists.txt
+@@ -77,7 +77,7 @@ TARGET_LINK_LIBRARIES(AbcExport
+
+ set_target_properties(AbcExport PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS AbcExport
+ DESTINATION ${ALEMBIC_MAYA_PLUGINS_INSTALL_DIR})
+diff --git a/maya/AbcImport/CMakeLists.txt b/maya/AbcImport/CMakeLists.txt
+index 6826183..e71e612 100644
+--- a/maya/AbcImport/CMakeLists.txt
++++ b/maya/AbcImport/CMakeLists.txt
+@@ -81,7 +81,7 @@ TARGET_LINK_LIBRARIES(AbcImport
+
+ set_target_properties(AbcImport PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS AbcImport
+ DESTINATION ${ALEMBIC_MAYA_PLUGINS_INSTALL_DIR})
+diff --git a/prman/Procedural/CMakeLists.txt b/prman/Procedural/CMakeLists.txt
+index 6b46e91..3635bcc 100644
+--- a/prman/Procedural/CMakeLists.txt
++++ b/prman/Procedural/CMakeLists.txt
+@@ -60,7 +60,7 @@ TARGET_LINK_LIBRARIES(AlembicRiProcedural Alembic::Alembic)
+
+ set_target_properties(AlembicRiProcedural PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+
+ INSTALL(TARGETS
+ AlembicRiProcedural
+diff --git a/python/PyAlembic/CMakeLists.txt b/python/PyAlembic/CMakeLists.txt
+index 91c45c4..c87eec6 100644
+--- a/python/PyAlembic/CMakeLists.txt
++++ b/python/PyAlembic/CMakeLists.txt
+@@ -128,7 +128,7 @@ IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
+ )
+
+ SET( ALEMBIC_PYTHON_INSTALL_DIR
+- lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+ CACHE PATH
+ "Alembic's python bindings install directory"
+ )
+@@ -143,7 +143,7 @@ IF (Boost_PYTHON_LIBRARY AND ALEMBIC_PYTHON_LIBRARY)
+
+ set_target_properties(alembic PROPERTIES
+ INSTALL_RPATH_USE_LINK_PATH TRUE
+- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
++ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ ELSE()
+ MESSAGE(FATAL_ERROR "Unable to find Python libs")
+ ENDIF()
diff --git a/media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch b/media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch
new file mode 100644
index 000000000000..4acdc5d7d885
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-find-pyilmbase-python-module.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/Modules/FindPyIlmBase.cmake b/cmake/Modules/FindPyIlmBase.cmake
+index 5cb9108..c3f80a2 100644
+--- a/cmake/Modules/FindPyIlmBase.cmake
++++ b/cmake/Modules/FindPyIlmBase.cmake
+@@ -44,7 +44,7 @@ ELSE()
+ SET(ALEMBIC_PYILMBASE_ROOT NOTFOUND)
+ ELSE()
+ # TODO: set to default install path when shipping out
+- SET(ALEMBIC_PYILMBASE_ROOT "/usr/local/pyilmbase/")
++ SET(ALEMBIC_PYILMBASE_ROOT "/usr")
+ ENDIF()
+ ELSE()
+ IF (${WINDOWS})
diff --git a/media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch b/media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch
new file mode 100644
index 000000000000..ca8bedef57ac
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-fix-python-import.patch
@@ -0,0 +1,30 @@
+diff --git a/cmake/Modules/FindPyIlmBase.cmake b/cmake/Modules/FindPyIlmBase.cmake
+index c677549..5cb9108 100644
+--- a/cmake/Modules/FindPyIlmBase.cmake
++++ b/cmake/Modules/FindPyIlmBase.cmake
+@@ -60,11 +60,11 @@ ELSE()
+
+ SET(LIBRARY_PATHS
+ ${ALEMBIC_PYILMBASE_ROOT}/lib
+- ${ALEMBIC_PYILMBASE_MODULE_DIRECTORY}
++# ${ALEMBIC_PYILMBASE_MODULE_DIRECTORY} # this is defined nowhere
+ ~/Library/Frameworks
+ /Library/Frameworks
+- /usr/local/lib
+- /usr/lib
++ /usr/local/lib${LIB_SUFFIX}
++ /usr/lib${LIB_SUFFIX}
+ /sw/lib
+ /opt/local/lib
+ /opt/csw/lib
+@@ -118,8 +118,8 @@ ELSE()
+ FIND_PATH(ALEMBIC_PYIMATH_MODULE_DIRECTORY imathmodule.so
+ PATHS
+ ${LIBRARY_PATHS}
+- /usr/local/lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+- ${ALEMBIC_PYILMBASE_ROOT}/lib64/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ /usr/local/lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ ${ALEMBIC_PYILMBASE_ROOT}/lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+ DOC "The imathmodule.so module directory"
+ )
+
diff --git a/media-gfx/alembic/files/alembic-1.7.9-prman.patch b/media-gfx/alembic/files/alembic-1.7.9-prman.patch
new file mode 100644
index 000000000000..cfd299c79bb0
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.7.9-prman.patch
@@ -0,0 +1,26 @@
+diff --git a/cmake/AlembicPRMan.cmake b/cmake/AlembicPRMan.cmake
+index e02b237..fdbf26c 100644
+--- a/cmake/AlembicPRMan.cmake
++++ b/cmake/AlembicPRMan.cmake
+@@ -66,8 +66,8 @@ ELSE()
+ ENDIF()
+
+ # Prefer PRMAN_ROOT set from the environment over the CMakeCache'd variable
+-IF(NOT $ENV{PRMAN_ROOT}x STREQUAL "x")
+- SET( ALEMBIC_PRMAN_ROOT $ENV{PRMAN_ROOT})
++IF(NOT $ENV{RMANTREE}x STREQUAL "x")
++ SET( ALEMBIC_PRMAN_ROOT $ENV{RMANTREE})
+ ENDIF()
+
+
+diff --git a/prman/Procedural/CMakeLists.txt b/prman/Procedural/CMakeLists.txt
+index 6b46e91..0cb2aa6 100644
+--- a/prman/Procedural/CMakeLists.txt
++++ b/prman/Procedural/CMakeLists.txt
+@@ -65,5 +65,5 @@ set_target_properties(AlembicRiProcedural PROPERTIES
+ INSTALL(TARGETS
+ AlembicRiProcedural
+ DESTINATION
+- prman/procedurals
++ $ENV{RMANTREE}/lib/plugins
+ )