summaryrefslogtreecommitdiff
path: root/media-gfx/album/album-4.15-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /media-gfx/album/album-4.15-r1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'media-gfx/album/album-4.15-r1.ebuild')
-rw-r--r--media-gfx/album/album-4.15-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/album/album-4.15-r1.ebuild b/media-gfx/album/album-4.15-r1.ebuild
new file mode 100644
index 000000000000..283dda684e5f
--- /dev/null
+++ b/media-gfx/album/album-4.15-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="HTML photo album generator"
+HOMEPAGE="https://marginalhacks.com/Hacks/album/"
+SRC_URI="https://marginalhacks.com/bin/album.versions/${P}.tar.gz
+ https://marginalhacks.com/bin/album.versions/data-4.05.tar.gz"
+
+LICENSE="marginalhacks"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc ffmpeg plugins themes"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ media-gfx/jhead
+ virtual/imagemagick-tools
+ ffmpeg? ( media-video/ffmpeg )"
+
+src_install() {
+ dobin album
+ doman album.1
+ dodoc License.txt CHANGELOG
+
+ if use doc ; then
+ docinto html
+ dodoc -r Docs/.
+ fi
+
+ dodir /usr/share/album
+ insinto /usr/share/album
+ cd .. || die
+ doins -r lang
+ use themes && doins -r Themes
+ use plugins && doins -r plugins
+}
+
+pkg_postinst() {
+ elog "For some optional tools please browse:"
+ elog "https://MarginalHacks.com/Hacks/album/tools/"
+}