summaryrefslogtreecommitdiff
path: root/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild')
-rw-r--r--media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
new file mode 100644
index 000000000000..d8730f7e978d
--- /dev/null
+++ b/media-fonts/zh-kcfonts/zh-kcfonts-1.05-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+S="${WORKDIR}"
+inherit eutils font toolchain-funcs
+
+MY_P="kcfonts-${PV}"
+DESCRIPTION="Kuo Chauo Chinese Fonts collection in BIG5 encoding"
+SRC_URI="ftp://freebsd.sinica.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ ftp://wm28.csie.ncu.edu.tw/pub/distfiles/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}-freebsd-aa_ad.patch.gz"
+HOMEPAGE="http://freebsd.sinica.edu.tw/"
+# no real homepage exists, but this was written by Taiwanese FreeBSD devs
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+DEPEND="x11-apps/bdftopcf"
+RDEPEND=""
+
+FONT_SUFFIX="pcf.gz"
+DOCS="00README Xdefaults.*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}/${MY_P}-freebsd-aa_ad.patch"
+ epatch "${FILESDIR}/${MY_P}-code-fixups.patch"
+ epatch "${FILESDIR}/${MY_P}-parallel-make.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}