summaryrefslogtreecommitdiff
path: root/media-fonts/noto/noto-20201226.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /media-fonts/noto/noto-20201226.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'media-fonts/noto/noto-20201226.ebuild')
-rw-r--r--media-fonts/noto/noto-20201226.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-fonts/noto/noto-20201226.ebuild b/media-fonts/noto/noto-20201226.ebuild
new file mode 100644
index 000000000000..439c26108925
--- /dev/null
+++ b/media-fonts/noto/noto-20201226.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit font
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlefonts/noto-fonts"
+
+COMMIT="2b1fbc36600ccd8becb9f894922f644bff2cbc9b"
+SRC_URI="https://github.com/googlei18n/noto-fonts/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+# Extra allows to optionally reduce disk usage even returning to tofu
+# issue as described in https://www.google.com/get/noto/
+IUSE="cjk +extra"
+
+RDEPEND="cjk? ( media-fonts/noto-cjk )"
+DEPEND=""
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/${PN}-fonts-${COMMIT}"
+
+FONT_SUFFIX="ttf"
+FONT_CONF=(
+ # From ArchLinux
+ "${FILESDIR}/66-noto-serif.conf"
+ "${FILESDIR}/66-noto-mono.conf"
+ "${FILESDIR}/66-noto-sans.conf"
+)
+
+src_install() {
+ mkdir install-unhinted install-hinted || die
+ mv unhinted/ttf/Noto*/*.tt[fc] install-unhinted/. || die
+ mv hinted/ttf/Noto*/*.tt[fc] install-hinted/. || die
+
+ FONT_S="${S}/install-unhinted/" font_src_install
+ FONT_S="${S}/install-hinted/" font_src_install
+
+ # Allow to drop some fonts optionally for people that want to save
+ # disk space. Following ArchLinux options.
+ use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.ttf
+}