summaryrefslogtreecommitdiff
path: root/media-fonts/noto-emoji
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-08 15:27:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-08 15:27:36 +0100
commit6721bc6137dee68e53e7b86a72184911e982697f (patch)
treed777396e74f24b4d7ebb26b7c68d89f81d0d1d32 /media-fonts/noto-emoji
parentafdfa05c5ce824f49340d033a80cdee422ac264a (diff)
gentoo auto-resync : 08:08:2023 - 15:27:36
Diffstat (limited to 'media-fonts/noto-emoji')
-rw-r--r--media-fonts/noto-emoji/Manifest2
-rw-r--r--media-fonts/noto-emoji/files/75-noto-emoji-fallback.conf31
-rw-r--r--media-fonts/noto-emoji/noto-emoji-20220912-r2.ebuild54
3 files changed, 87 insertions, 0 deletions
diff --git a/media-fonts/noto-emoji/Manifest b/media-fonts/noto-emoji/Manifest
index 5513a36918a3..3f6461222b0b 100644
--- a/media-fonts/noto-emoji/Manifest
+++ b/media-fonts/noto-emoji/Manifest
@@ -1,3 +1,5 @@
+AUX 75-noto-emoji-fallback.conf 1307 BLAKE2B c26f8efcc88bdf4865c54c52a538c3f87552344a42fedca61e227524275cf736b5c456eec4dfb6bb747209f4540eec79904ad9df062bfcf213b2f665408975bd SHA512 a67043984032f5f65e361289c316c2d9b9c04975d2d305df85b5d4b22a036c7791714daf9950be2f7c7e252c0f93925002db699d68c7d803cdbd532d98385b64
DIST noto-emoji-20220912.tar.gz 178768907 BLAKE2B b998a74903e0a559e6c2d87f6d05649054728d5359659882c89b99fc41ec80f9dbafba6f418500059acef7bb85b9d60b189abea286c9c4cb5491f501095ca425 SHA512 4e9b01be1ac7853d840379f84350f2709212401ccebb221308eb83982a8673af9a8ef166952aba4d6f8d9939efc4989f38a7db69e022eb055f265ccba78884a6
EBUILD noto-emoji-20220912-r1.ebuild 1080 BLAKE2B a4c6e0f837608f51523dff6e414028d4a431440b168ff09fe2a58aeb591f616b10c1d9286dd6c90264230a19cd7839779a4525a5b7a298c306479d169e248914 SHA512 972f135f49d4434f016d5f1de1d0f2e0f8aa40d5c579dd556883629e7f4e3cc3d693fc57299a5bf7fb465e4b63f5f0db82c529b4699af9d426f6af2007cc81f3
+EBUILD noto-emoji-20220912-r2.ebuild 1186 BLAKE2B 5fe47c16d87939aff785048092618fb60a4a72fe9161ed23f22fcfe3a10444bcda6097b2d55dc221eba8b5d02b19fb236ec579d717f902450852087b4401f67a SHA512 5f50655c2db25ce27142198b9f5bd530d739bc24997cd5e0716788faf09781ec32724783c37d7edb7e4a85848fa50cc52a50d4206fed5606bf5a77d80281e2bd
MISC metadata.xml 404 BLAKE2B 22cf87041f4f6f5c051fd1d65b9f3355ed1bef0b30f85f9fe16e6857a00e0a4b6fe5e87558a4f5c170f5fd4247d045116d65a3a2d4d14d9767785946a14dbd21 SHA512 2bf090e6377ca15a0ee429d8541e3731d3deb0ea06120bb5ee77cb26f346eb5a0d9d9a05a6af31e940cd8470099bc5d3507f72b98fbf0a9dc0273073acfa6eed
diff --git a/media-fonts/noto-emoji/files/75-noto-emoji-fallback.conf b/media-fonts/noto-emoji/files/75-noto-emoji-fallback.conf
new file mode 100644
index 000000000000..deb9c965b8b5
--- /dev/null
+++ b/media-fonts/noto-emoji/files/75-noto-emoji-fallback.conf
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+:
+ <!-- This adds Noto Color Emoji as a fallback font for all of the default font families;
+ When enabled any **missing** glyphs from the system font will be rendered using Noto Color Emoji in (e.g.)
+ Konsole, Firefox, etc. It _might_ impact web rendering if other fonts would usually be preferred
+ but as it's only doing replacements for missing glyphs we're really just supplementing
+ the existing fallback logic -->
+
+ <match target="pattern">
+ <test name="family"><string>sans</string></test>
+ <edit name="family" mode="append"><string>Noto Color Emoji</string></edit>
+ </match>
+
+ <match target="pattern">
+ <test name="family"><string>serif</string></test>
+ <edit name="family" mode="append"><string>Noto Color Emoji</string></edit>
+ </match>
+
+ <match target="pattern">
+ <test name="family"><string>sans-serif</string></test>
+ <edit name="family" mode="append"><string>Noto Color Emoji</string></edit>
+ </match>
+
+ <match target="pattern">
+ <test name="family"><string>monospace</string></test>
+ <edit name="family" mode="append"><string>Noto Color Emoji</string></edit>
+ </match>
+
+ </fontconfig>
diff --git a/media-fonts/noto-emoji/noto-emoji-20220912-r2.ebuild b/media-fonts/noto-emoji/noto-emoji-20220912-r2.ebuild
new file mode 100644
index 000000000000..5d3bb6b9ac76
--- /dev/null
+++ b/media-fonts/noto-emoji/noto-emoji-20220912-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit font
+
+DESCRIPTION="Google Noto Emoji fonts"
+HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlefonts/noto-emoji"
+
+COMMIT="e8073ab740292f8d5f19b5de144087ac58044d06"
+SRC_URI="https://github.com/googlefonts/noto-emoji/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="icons"
+
+RESTRICT="binchecks strip"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# https://github.com/gentoo/gentoo/pull/32203
+FONT_CONF=( "${FILESDIR}"/75-noto-emoji-fallback.conf )
+
+src_prepare() {
+ default
+
+ # Drop font for Windows 10
+ rm fonts/NotoColorEmoji_WindowsCompatible.ttf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ FONT_S="${S}/fonts"
+ # Drop non used fonts
+ rm -f fonts/*COLR*.ttf || die
+
+ # Don't lose fancy emoji icons
+ if use icons; then
+ for i in 32 72 128 512; do
+ insinto "/usr/share/icons/${PN}/${i}/emotes/"
+ doins png/"${i}"/*.png
+ done
+
+ insinto /usr/share/icons/"${PN}"/scalable/emotes/
+ doins svg/*.svg
+ fi
+
+ FONT_SUFFIX="ttf"
+ font_src_install
+
+ dodoc README.md
+}