summaryrefslogtreecommitdiff
path: root/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild')
-rw-r--r--media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
new file mode 100644
index 000000000000..28e50869faf5
--- /dev/null
+++ b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit font font-ebdftopcf
+
+DESCRIPTION="Japanese fixed fonts that cover JIS0213 charset"
+
+HOMEPAGE="http://www12.ocn.ne.jp/~imamura/jisx0213.html"
+SRC_BASE1="http://www12.ocn.ne.jp/~imamura"
+SRC_BASE2="http://gitatsu.hp.infoseek.co.jp/bdf"
+SRC_URI="${SRC_BASE1}/jiskan16-2004-1.bdf.gz
+ ${SRC_BASE1}/jiskan16-2000-1.bdf.gz
+ ${SRC_BASE1}/jiskan16-2000-2.bdf.gz
+ ${SRC_BASE1}/K14-2004-1.bdf.gz
+ ${SRC_BASE1}/K14-2000-1.bdf.gz
+ ${SRC_BASE1}/K14-2000-2.bdf.gz
+ ${SRC_BASE1}/K12-1.bdf.gz
+ ${SRC_BASE1}/K12-2.bdf.gz
+ ${SRC_BASE1}/A14.bdf.gz
+ ${SRC_BASE1}/A12.bdf.gz
+ ${SRC_BASE2}/jiskan24-2000-1.bdf.gz
+ ${SRC_BASE2}/jiskan24-2000-2.bdf.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="alpha amd64 arm ia64 ppc s390 sh sparc x86 ~x86-fbsd"
+
+S="${WORKDIR}"
+FONT_S="${S}"
+FONT_PN="${PN/-fonts/}"
+FONTDIR="/usr/share/fonts/${FONT_PN}"
+
+# Only installs fonts
+RESTRICT="strip binchecks"
+
+pkg_postinst(){
+ if use X; then
+ elog "You need you add following line into 'Section \"Files\"' in"
+ elog "XF86Config and reboot X Window System, to use these fonts."
+ elog ""
+ elog "\t FontPath \"${FONTDIR}\""
+ elog ""
+ fi
+}