summaryrefslogtreecommitdiff
path: root/media-fonts/font-misc-ethiopic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-fonts/font-misc-ethiopic
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-fonts/font-misc-ethiopic')
-rw-r--r--media-fonts/font-misc-ethiopic/Manifest2
-rw-r--r--media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/media-fonts/font-misc-ethiopic/Manifest b/media-fonts/font-misc-ethiopic/Manifest
index 86d336fc4f9f..5b674f5b069d 100644
--- a/media-fonts/font-misc-ethiopic/Manifest
+++ b/media-fonts/font-misc-ethiopic/Manifest
@@ -1,3 +1,5 @@
DIST font-misc-ethiopic-1.0.3.tar.bz2 245606 BLAKE2B e0cf89f4500226b7213d6f3f88b3bf575501140d8742fe5e30b07eefd2c1fe2fc9bfe941639032d3b5ce45eb7e6f352af7b6468e7f8b0fc941ed9cee8d531f96 SHA512 b3e3f7462f37216796730a894761c7d60d5ede0f51351997e6c3c92e3136c788a2710690f482d05ed1396a4b6be452e1f871febc7e5b7a1a67e43bcc1ec7c77d
+DIST font-misc-ethiopic-1.0.4.tar.bz2 270076 BLAKE2B b27d188fcb5be3e4e5fed810f26c0f5edf5a51a3532bd51b44e55283518bc1a353054da4f37c5535197eeb6958bfe1567ab54d1d9f428b046b84c5d1233aae21 SHA512 4fed9ff3782746898c56dac199e9ca89356f4967779937049b9ff4ffad202317c023859f92d44b371dfa5485d5368ccad648e64b12cde0ed21f7d4aee5affcd5
EBUILD font-misc-ethiopic-1.0.3-r1.ebuild 519 BLAKE2B 8ea8d1ca143c4269f00e7003cd35e69548f4dcd9023760a77d09a7991bcd275df9f37631a126e777a71e9a7c717fa8a051ff4c273b76aac4cdecdf702f84eadd SHA512 6ab2706eb1ee5e0de1f0c6096d72598285405d89cbf9c5d0a0f3acd8e050bb1777a892e01ebbadad92efd8c4006bf5ebdc5e88bc3c6d2790b08b8d025c48891b
+EBUILD font-misc-ethiopic-1.0.4.ebuild 703 BLAKE2B d75205c5f35eedc04a855b3b256e21023817f06b9c865c4e33473c7abf90af155b8a49f260ff621d2e6a7f76eaca0c72b860985081069a9836f3204bcaa36916 SHA512 79d6f9c2588b3f6b2dda01601a3002bbaada8939a5231b3a1b38b4e5d5c499693eb62d6fb4ce70d47a0ff1accafbc9c3be09e046742953a66ef308435b1ee42d
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild
new file mode 100644
index 000000000000..cc322ce05390
--- /dev/null
+++ b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+FONT_DIR="OTF"
+
+inherit xorg-3
+
+DESCRIPTION="Miscellaneous Ethiopic fonts"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-fontrootdir="${EPREFIX}/usr/share/fonts"
+
+ # This flag unexpectedly doesn't control whether the font (i.e. the .ttf file)
+ # is installed, but instead only controls whether mkfontscale/mkfontdir is
+ # run. I suspect this is a bug.
+ --disable-truetype-install
+)
+
+src_install() {
+ xorg-3_src_install
+
+ # TTF fonts are not supposed to be installed.
+ rm -r "${ED}/usr/share/fonts/TTF" || die
+}