summaryrefslogtreecommitdiff
path: root/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 04:02:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 04:02:51 +0000
commit87f37a073fb5c2e1f6ebc780e60cdbdd2c583860 (patch)
tree9872190e1841d9f126084652bf3b6b2687c6f1bb /media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild
parenta87296ad796f00f3bba27339f6efe11b9a384e23 (diff)
gentoo auto-resync : 28:02:2023 - 04:02:51
Diffstat (limited to 'media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild')
-rw-r--r--media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild
new file mode 100644
index 000000000000..fc918c94867e
--- /dev/null
+++ b/media-fonts/font-misc-ethiopic/font-misc-ethiopic-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+FONT_DIR="OTF"
+XORG_TARBALL_SUFFIX="xz"
+XORG_PACKAGE_NAME="misc-ethiopic"
+inherit xorg-3
+
+DESCRIPTION="Miscellaneous Ethiopic fonts"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-fontrootdir="${EPREFIX}/usr/share/fonts"
+
+ # This flag unexpectedly doesn't control whether the font (i.e. the .ttf file)
+ # is installed, but instead only controls whether mkfontscale/mkfontdir is
+ # run. I suspect this is a bug.
+ --disable-truetype-install
+)
+
+src_install() {
+ xorg-3_src_install
+
+ # TTF fonts are not supposed to be installed.
+ rm -r "${ED}/usr/share/fonts/TTF" || die
+}