summaryrefslogtreecommitdiff
path: root/mate-extra/mate-system-monitor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /mate-extra/mate-system-monitor
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'mate-extra/mate-system-monitor')
-rw-r--r--mate-extra/mate-system-monitor/Manifest2
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index bbfc9c18005b..493252ca73b5 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,3 +1,5 @@
DIST mate-system-monitor-1.18.1.tar.xz 2159100 BLAKE2B babac7ad0dc3a3bccf5c6d4567bee0c95aad1f5fffdb1d6d566316f4712a345e7083c8032c19b6615a9f9d06fbbe8b89357407b897206f3131294b7d2305b45d SHA512 47dd2ba46cd6fbd1beef2e6f0a93332c7142f701d18f6894b4986134c557f63f3e2bed382af17cc5bf45693b556a91ccab36fde940126fdceb5834d4cea08356
+DIST mate-system-monitor-1.22.0.tar.xz 2190688 BLAKE2B 83ab7dfbc0033f094896c663790c1200e71a498d3a813a82c94593e6c6434942b2afd0fa1c3067452a46e0e1829a9239f1c145a315b9de2c2853c9f4f50618ef SHA512 6f97f934626b49320ea0dbb4e14743c4f33b12a85671b69465f689765f3003f00e51685b616e34a482c3ec0ca09ca4e13cbdb2e3eb4719c0d1fc7b25b24436a7
EBUILD mate-system-monitor-1.18.1.ebuild 1016 BLAKE2B 1bbe2ee50460b8c3db678d658df3228e999fdf10bd887365a72ab8a8b26207db3df6a5b70a93b0e562203c766f3f6e84c46e18ee234ca78374ff8fd1b418cad9 SHA512 1d773cd89876cbbf9c0b3e7a16561b797d1272c5b412e860f7c0e9f5586ef8e4924e810f5629c8ea32cfeb38275a7ea3a21ffda6002e910f262be472d2eabd1c
+EBUILD mate-system-monitor-1.22.0.ebuild 881 BLAKE2B 8ac8388e3e6291534328a317cffab7c847723a7f1a0339023da73015e725183416d84e9181390614392f8dd1e003bc865703ab2510fc1df57f4c038b8cd83625 SHA512 25f998324182133b3ee1e9ddf3481f110a929ca2e22621f46193b9903f6423944c95d426f38a28e132ee6d9eeb670e0854838caccd3b8aa49711e27ca48bfb0d
MISC metadata.xml 348 BLAKE2B fe7ff06b7a0366617fb30e7a98fa7054c32469bf49691855183ee7b9991c1aebd5f431081e5d7efe07ab3a2b2424630bea621c2b3369338f6bb5348d1ba70de7 SHA512 4cb1bd5f11887274393c957be697ce784af74a39258ead2e9ccb586ac8d4bcab06a6aa2a76e8f96a85d2d818092250eede243775b61222493739440c59cc9c9b
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild
new file mode 100644
index 000000000000..58b518131b09
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.22.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="systemd"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.50:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.23.1:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ virtual/libintl
+ systemd? ( sys-apps/systemd )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ >=sys-devel/autoconf-2.63:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable systemd)
+}