summaryrefslogtreecommitdiff
path: root/mate-extra/mate-polkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /mate-extra/mate-polkit
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'mate-extra/mate-polkit')
-rw-r--r--mate-extra/mate-polkit/Manifest1
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.24.0-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/Manifest b/mate-extra/mate-polkit/Manifest
index 769fedf5835f..24bc9d24f3ea 100644
--- a/mate-extra/mate-polkit/Manifest
+++ b/mate-extra/mate-polkit/Manifest
@@ -1,3 +1,4 @@
DIST mate-polkit-1.24.0.tar.xz 332652 BLAKE2B 293d964f2410d2f60047d1e01e2ba864c22e8bda00e5b659329d097391b2988349c70dfbd953f223c4212887d16d54f1f5a7eb21e38b69b553d54b1966647cb1 SHA512 8d759bd5f78750c75dc92ffa27e555ae36ae7199b76483cbfe7e0848d3a66cda5b82c98bf334068eb79a1344757665cf7d1bf403e4e908e332ca929c8ebe2a98
+EBUILD mate-polkit-1.24.0-r1.ebuild 890 BLAKE2B 014164db70e1bd8b397216399094311e43f3612cba45c2cc51dc643a12d8f8aac9ecc941e055f86eff7ecba18e4401f343c72275b31ebabf3f8b402f6e8daad4 SHA512 b376f1108c45bfce0aceb36382df13982dfd6faece4f5ad61b1e40787096bad2eede67c726d3878bf56b6642e6ff5139a8f74c68474e51a904f12a20c69c5908
EBUILD mate-polkit-1.24.0.ebuild 909 BLAKE2B 9f1ea23a2968804672ee3e5a71cf1c76115ad5d0e2dd6badea0168ef9ea3f50ec40f3f4e639957af57c7ea06a7e53d486954ad911bf36f99adec5c4761828ccc SHA512 f1e68e833cefcf16c5fd53e9e96abd4169d0269fc44df508a1a929ae6ff8bd8397a5c9207bd31fcd043d7c79d8cbfbb641d9869ea7ff621f6c1528def6562dde
MISC metadata.xml 441 BLAKE2B 299b65dc443f658b080598b7e1dad457948870b53964f1fdf532192c5c4062ffcca29660003fd45bd6ac376f00b6511b5582ecc312c312179979a47ce9c4819a SHA512 dd57c92f8a4881df822821fa48ba75ea02eac47728fd2250fd15d79758be30b4dcc6bfcc7945de9b57bb64dde4139d32797ebbb7678b0d619c41c2eaaeb3129d
diff --git a/mate-extra/mate-polkit/mate-polkit-1.24.0-r1.ebuild b/mate-extra/mate-polkit/mate-polkit-1.24.0-r1.ebuild
new file mode 100644
index 000000000000..429c5e890f73
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.24.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=sys-auth/polkit-0.102
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22.0:3
+ appindicator? ( dev-libs/libappindicator:3 )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ accountsservice? ( sys-apps/accountsservice )
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig
+ !<gnome-extra/polkit-gnome-0.102:0
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}