summaryrefslogtreecommitdiff
path: root/mate-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 06:00:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 06:00:45 +0000
commite660fe12946bfa241d169ebb2467939907de75d8 (patch)
tree4b2ba6aedbeadcf69d25b78526ac31be8e432a90 /mate-base
parentca7fcaa76aaf1f94284894a8d9a01bb153e80b11 (diff)
gentoo auto-resync : 20:01:2023 - 06:00:45
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/Manifest.gzbin2228 -> 2229 bytes
-rw-r--r--mate-base/mate-panel/Manifest2
-rw-r--r--mate-base/mate-panel/mate-panel-1.26.2.ebuild72
3 files changed, 74 insertions, 0 deletions
diff --git a/mate-base/Manifest.gz b/mate-base/Manifest.gz
index f86a33a2d578..c347aa0f45a8 100644
--- a/mate-base/Manifest.gz
+++ b/mate-base/Manifest.gz
Binary files differ
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index ce3697745121..e58d4d76c0ee 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1,3 +1,5 @@
DIST mate-panel-1.26.0.tar.xz 3303980 BLAKE2B b36ddb6d4db174bd26986193829e72e498f81e31d129aa0e64ef3927b3571b58c3bb940a1d3c4ceb14165d5d7810d812a3b39dd2ea7aad4bd9cdaf4dae84751e SHA512 394cf6a4a081980d286a03488370a5335dca681964271329b28d7254fc877457bc42883c95ad9f197a319f1bef71e237052d64b98606df616f5e11b9f9ae5f31
+DIST mate-panel-1.26.2.tar.xz 3314092 BLAKE2B 6b33562728b7ffa3bc1c5a3341e2bd4b88c5daba504e6818810f194d8a6f736ac5b5936ed10c17ad5879eaa7a3e7f2a7d0dad6e59e7582d684f9bcdbb8421ddf SHA512 31f97b5cbacd5ac4a3661fdb8544313e5fb406489c9179d98c0f981001beae97890f3563bbf5886c451cf27db7235bfe70d40bf2582bc2e2206dadd396432ec7
EBUILD mate-panel-1.26.0-r1.ebuild 1527 BLAKE2B 6ff29720099d1d82ee934ab1bfdfd60eaba8ac65d1b866367c5b44576ff5594ceb7d1784cdac983b0998ba6401fdd16e0b5e6cf8910665af04f4c0aaea724d25 SHA512 4986037a4b469bf6bdfe565e140f9f621f3534d92554de3843ed5095f5c77cb7d64201c1e5ae1595864b8a2cf8bfce2e614663e7226278e1989d118b774ee0be
+EBUILD mate-panel-1.26.2.ebuild 1504 BLAKE2B 7dc9c4cbb4d501ce0ba510dfdd605efe173c6c291594103707ec0122a67cf231a97a378be688cb98f17da62596939ecbc2e3604b4b331a8bfb5f5650f897892b SHA512 f8da0e23b9e7afe780acd72b8917c32b60496e352300e483ffa3595d2fee2def96b2d62460b11b36452cea183d1b01f56a35ef8de46b3f1556e1d33fd67bd3e0
MISC metadata.xml 340 BLAKE2B a746123a3dde50f47bd8e0a9e83387e0a227cc3c1ad36b3747532023667bb88417311dd7d558cb0f10b449a23443042c0018210c5d544deb2c5f60fa55d33dec SHA512 2933048f84f8d606095f7752f2bfc4bb16225632bd292184ca80dc1c6ab7cb28b54b56d77db778fb9ea5037c7e39e557d74fa03151dbaae021a5664bd569e973
diff --git a/mate-base/mate-panel/mate-panel-1.26.2.ebuild b/mate-base/mate-panel/mate-panel-1.26.2.ebuild
new file mode 100644
index 000000000000..56d6e902fa3d
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.26.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+X +introspection wayland"
+
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1.0.0[X?]
+ >=x11-libs/gdk-pixbuf-2.26.0:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ X? (
+ x11-libs/libX11
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}