summaryrefslogtreecommitdiff
path: root/mate-base/mate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /mate-base/mate
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'mate-base/mate')
-rw-r--r--mate-base/mate/Manifest1
-rw-r--r--mate-base/mate/mate-1.22.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/mate-base/mate/Manifest b/mate-base/mate/Manifest
index ec4541ab5f43..c44ae508eb5e 100644
--- a/mate-base/mate/Manifest
+++ b/mate-base/mate/Manifest
@@ -1,2 +1,3 @@
EBUILD mate-1.18.ebuild 2576 BLAKE2B cc156c65df6b3d72b2abb6cc0c49131d0eba04e3c9da771304aa04c51a41cce63f2deaf06393ad689cd3f6985b7c51f51d4fff3b1edd197a78a34d831b9cc8f8 SHA512 75841b52b473e25e4436099963000fab949cd89272d0f68fb664a5f155625b208a900c3463e1d524412dfe951639de597533733923b84aae3e40626011f47fba
+EBUILD mate-1.22.ebuild 2491 BLAKE2B e8dfe19753da5e4cda977c196020ccf6e54567cc82a63251e69cef7489c4a4842067f8cfe3c9e8e395f8c7419c2c1def52f5ef5ba55d51ce6e9b33f1edca7771 SHA512 7468d6f82cd813ba8366a54423d254d514f4c380ba777113070abdd6a3094c97a3d0ba4e3bee3daad1386b080bf6e3e41853a67216610b2cb7807981bc4f816c
MISC metadata.xml 1342 BLAKE2B da370118ca35235d9015c6fca17a4766067c1bb5393a68cbb84caa724ef970cb30925c6c5b4eb59fdc5d67eebf6c7031173de7bf868a61108cb5bb7354207d3e SHA512 cd369cf3b32404c16975cdda320043b27898838b2d5c3732bbe2a62f16332eab9f55a2c00e7f8bb1f98cc5cf7d00ec6fe40b74a106b7b72db5f252ec576aff85
diff --git a/mate-base/mate/mate-1.22.ebuild b/mate-base/mate/mate-1.22.ebuild
new file mode 100644
index 000000000000..eb43ab877759
--- /dev/null
+++ b/mate-base/mate/mate-1.22.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ MATE_BRANCH=9999
+ MATE_THEMES_V=9999
+else
+ inherit eapi7-ver
+ MATE_BRANCH="$(ver_cut 1-2)"
+ MATE_THEMES_V=3
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+SRC_URI=""
+DESCRIPTION="Meta ebuild for MATE, a traditional desktop environment"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="metapackage"
+
+SLOT="0"
+IUSE="+base -bluetooth help +notification +themes +extras"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ =mate-base/mate-desktop-${MATE_BRANCH}*
+ =mate-base/mate-menus-${MATE_BRANCH}*
+ =mate-base/mate-panel-${MATE_BRANCH}*
+ =mate-base/mate-session-manager-${MATE_BRANCH}*
+ =mate-base/mate-settings-daemon-${MATE_BRANCH}*
+ =x11-wm/marco-${MATE_BRANCH}*
+ base? (
+ =mate-base/caja-${MATE_BRANCH}*
+ =mate-base/mate-applets-meta-${MATE_BRANCH}*
+ =mate-base/mate-control-center-${MATE_BRANCH}*
+ =mate-extra/mate-media-${MATE_BRANCH}*
+ =x11-misc/mozo-${MATE_BRANCH}*
+ =x11-terms/mate-terminal-${MATE_BRANCH}*
+ )
+ bluetooth? ( net-wireless/blueman )
+ themes? (
+ =x11-themes/mate-backgrounds-${MATE_BRANCH}*
+ =x11-themes/mate-icon-theme-${MATE_BRANCH}*
+ >=x11-themes/mate-themes-meta-${MATE_THEMES_V}
+ )
+ extras? (
+ =app-arch/engrampa-${MATE_BRANCH}*
+ =app-editors/pluma-${MATE_BRANCH}*
+ =app-text/atril-${MATE_BRANCH}*
+ =mate-extra/caja-extensions-${MATE_BRANCH}*
+ =mate-extra/mate-calc-${MATE_BRANCH}*
+ =mate-extra/mate-netbook-${MATE_BRANCH}*
+ =mate-extra/mate-power-manager-${MATE_BRANCH}*
+ =mate-extra/mate-screensaver-${MATE_BRANCH}*
+ =mate-extra/mate-system-monitor-${MATE_BRANCH}*
+ =mate-extra/mate-utils-${MATE_BRANCH}*
+ =media-gfx/eom-${MATE_BRANCH}*
+ sys-apps/gnome-disk-utility
+ )
+ help? (
+ gnome-extra/yelp
+ =mate-extra/mate-user-guide-${MATE_BRANCH}*
+ )
+"
+
+PDEPEND="
+ notification? ( =x11-misc/mate-notification-daemon-${MATE_BRANCH}* )
+ virtual/notification-daemon:0"
+
+pkg_postinst() {
+ elog "For installation, usage and troubleshooting details regarding MATE;"
+ elog "read more about it at Gentoo Wiki: https://wiki.gentoo.org/wiki/MATE"
+ elog ""
+ if ! has_version x11-misc/mate-notification-daemon; then
+ elog "If you experience any issues with notifications, please try using"
+ elog "x11-misc/mate-notification-daemon instead your currently installed daemon"
+ elog ""
+ fi
+ elog "Some packages that are not included in this meta-package but may be of interest:"
+ elog " mate-extra/caja-dropbox"
+ elog " mate-extra/mate-user-share"
+}