summaryrefslogtreecommitdiff
path: root/mate-base/mate-panel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /mate-base/mate-panel
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'mate-base/mate-panel')
-rw-r--r--mate-base/mate-panel/Manifest2
-rw-r--r--mate-base/mate-panel/mate-panel-1.22.1.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index bee1960dc07f..9c6207e96d27 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1,3 +1,5 @@
DIST mate-panel-1.22.0.tar.xz 2251040 BLAKE2B 6a4da6080cec2fc7858c711fa0a2c7497f4d03a1e22394f481925be32b17f7905920d4155ca75b9bf0d6bbf4af078aac77abc99e6d5a22e84bf453e2290ba032 SHA512 078c6dcdc17970a7a7fab9a218eaf2c8cd6c4074c0c23ff4ce7ccf57e007d0afcbe797be4ad4c9d2c16d9033cc554cc5a979ec61dc721514db939a5e60de456b
+DIST mate-panel-1.22.1.tar.xz 2142620 BLAKE2B 3b105c04cd2c1bf0c5077fb79dc8f0fea090eca96b766567a3921c25d35f915d36446ad765fd226f2fc2a70d4c95987a1c503bd60a92210f944fb50a83bc6a90 SHA512 023599a2c0a879e32df11fc09d7526a54b8dc5248173c940e61df1dd9cbe8c04e4c916da89f5a64e44fe3f99462d56c72849314fc182c0af58a7c19e1fac642f
EBUILD mate-panel-1.22.0.ebuild 1350 BLAKE2B 4ce80bd99af1ec21b05dc2368be45a26a3c3b92fa2142cb1a8d6626e7fae4c7e373b31eb8f7ed2f3820a230ce954cc167c37aad00b8bd39b43f08a6113a45fc3 SHA512 07be1580b09cbe9e8b4d92d5972a68e67738efd67278f009598ec5b122ddbc8a1d34962193fe4d78534586c5443a0371774904882431dd60e6387a97edcb2d39
+EBUILD mate-panel-1.22.1.ebuild 1420 BLAKE2B 5ee1b7f38e5f335268535119dfb8f07788fa00252f7650756d9ac3ca3486e273fcd4325663ccbef2c7fbc9b1ceaa6f706b5d872c414b6002144215dc6b1b9fe2 SHA512 53d6dac4fef0e25623d4626dde7f8d6efae0df3ef600b92b25bfb839aa4290f526feca15987ac2e0f21e72e9e96c9f8a8d9261ad1479a1c32d818351d578a62d
MISC metadata.xml 339 BLAKE2B d4e26fe24b5076b1a78c8de45bab802a438bd5fc171da7a6da6dc2460a7cb53677d4044abefc6c925a1b56d60d1a20fcb2334121ac0750d8347dc8ca3497b9c7 SHA512 788f53b6c90c485f6c8e4de2a9d1fd8f895b7c57cb7beeb0ec295a4710ceac5c8537ec9b3b567fbb5fae95cc08ce8892649a4198d40f30363b98f01267d67d26
diff --git a/mate-base/mate-panel/mate-panel-1.22.1.ebuild b/mate-base/mate-panel/mate-panel-1.22.1.ebuild
new file mode 100644
index 000000000000..fdfc53f24428
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.22.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X +introspection wayland"
+
+RDEPEND="
+ dev-libs/atk
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4
+ >=gnome-base/librsvg-2.36.2:2
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.21.0
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1
+ >=x11-libs/gdk-pixbuf-2.25.2:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libwnck-3.4.6:3[introspection?]
+ x11-libs/libX11
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.3
+ virtual/libintl
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ wayland? ( dev-libs/wayland )"
+
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-lang/perl-5:=
+ dev-util/glib-utils
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_enable X x11) \
+ $(use_enable introspection) \
+ $(use_enable wayland)
+}