summaryrefslogtreecommitdiff
path: root/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 23:37:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 23:37:47 +0100
commit6990d0600970cefe6aa2c17668f9028b08d23441 (patch)
treeb106c69cf74dd70e162c879310bdf2fd49a16f6a /mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild
parentc7c8d625ecbe5f95c445995303ed9b0e1f0de507 (diff)
gentoo auto-resync : 10:04:2023 - 23:37:47
Diffstat (limited to 'mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild')
-rw-r--r--mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild
new file mode 100644
index 000000000000..f05292d8f63e
--- /dev/null
+++ b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd xdg-utils
+
+MY_PN="${PN/-mail/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Serves ProtonMail to IMAP/SMTP clients"
+HOMEPAGE="https://proton.me/mail/bridge https://github.com/ProtonMail/proton-bridge/"
+SRC_URI="https://github.com/ProtonMail/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-3+ ISC LGPL-3+ MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gui"
+
+# Quite a few tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="app-crypt/libsecret"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ xdg_environment_reset
+ default
+}
+
+src_compile() {
+ if use gui; then
+ eerror "Since version 3.0.0, GUI support in ${PN} requires Qt6 and is therefore currently not available"
+ die "USE=gui requires Qt6"
+ else
+ emake build-nogui
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe bridge ${PN}
+
+ systemd_newuserunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use gui && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gui && xdg_icon_cache_update
+}