summaryrefslogtreecommitdiff
path: root/mail-mta/notqmail/notqmail-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /mail-mta/notqmail/notqmail-9999.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'mail-mta/notqmail/notqmail-9999.ebuild')
-rw-r--r--mail-mta/notqmail/notqmail-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/mail-mta/notqmail/notqmail-9999.ebuild b/mail-mta/notqmail/notqmail-9999.ebuild
index b5ff5be5d0e3..eb09e7fa8d30 100644
--- a/mail-mta/notqmail/notqmail-9999.ebuild
+++ b/mail-mta/notqmail/notqmail-9999.ebuild
@@ -13,13 +13,13 @@ QMAIL_BIGTODO_F=notqmail-1.08-big-todo.patch
QMAIL_LARGE_DNS="qmail-103.patch"
-inherit qmail
+inherit qmail systemd
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/notqmail/notqmail.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc"
+ KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
SRC_URI="https://github.com/notqmail/notqmail/releases/download/${P}/${P}.tar.xz"
fi
@@ -142,11 +142,13 @@ src_prepare() {
src_compile() {
qmail_src_compile NROFF=true
+ emake qmail-send.service
use qmail-spp && qmail_spp_src_compile
}
src_install() {
qmail_src_install
+ systemd_dounit "${S}"/qmail-send.service
}
src_test() {