summaryrefslogtreecommitdiff
path: root/mail-filter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /mail-filter
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/Manifest.gzbin11371 -> 11375 bytes
-rw-r--r--mail-filter/pypolicyd-spf/Manifest2
-rw-r--r--mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/mail-filter/Manifest.gz b/mail-filter/Manifest.gz
index e5261dfe8a79..2824bfe2ea66 100644
--- a/mail-filter/Manifest.gz
+++ b/mail-filter/Manifest.gz
Binary files differ
diff --git a/mail-filter/pypolicyd-spf/Manifest b/mail-filter/pypolicyd-spf/Manifest
index a3088fbe3c02..df7c748d8869 100644
--- a/mail-filter/pypolicyd-spf/Manifest
+++ b/mail-filter/pypolicyd-spf/Manifest
@@ -1,3 +1,5 @@
DIST pypolicyd-spf-2.0.1.tar.gz 38086 BLAKE2B 70d13722000548eac9bb9a6ff80913e88b18227f1a90b864e4fc7749b8e0886e56fff6694d514ed0becb32ca129023cb9e66af3f33a4d4390c8c8c05affa1fb6 SHA512 85f51491ab1f44e197dbf9a15f9e723ba3aaf0472d9d1653595490d7211670a67cdca5699111ab5a29f9d919cd935ed58d8d70bd1312a4f0f90da4ef26a50509
+DIST pypolicyd-spf-2.0.2.tar.gz 38546 BLAKE2B 691cd5db37592be0ef0cda41223280e764e83802e37563f4e6c08505731118199c03d27b0bf51cec0556aa946fc6c7465fe09d3c9100c8e2582a4d85ad828495 SHA512 adcc7b30c6922894f9407edd0637b02a138623f4480ec37635475396826b457c835b3ffb599d1985e306770fe5f72404552ed705bd957e63b5c54ca3d8991673
EBUILD pypolicyd-spf-2.0.1.ebuild 1229 BLAKE2B 55192ce4b93e9517464a346e54116aee1fea7e3dd320d96b7a5701c6b2803f4420851552d7bb5c8776278f037c1f15d2aa854a5cffa0fa6693d372db0fde3bac SHA512 564469702551ba214455b51385810e2149848ca15ab55b646e2a4c4195efd0be387f504bf6c1e640dbf0428876f14149b77c8ee797098a697fae1c99d6743a35
+EBUILD pypolicyd-spf-2.0.2.ebuild 1223 BLAKE2B 20479d4c2d06411769111ada8525d13c0b382b5dd06ec6b652ef8966fac9118cf5efa2c56bc32ff561a43ba09524508bd5e9691eeacd1bcbbbc1052c655a1955 SHA512 d96db6c5673798ced4374e01724b94c2ca77bcbbfaa7d8e9e08b262e0ee05a6325a7758cc5811a174de6e7dfd91c7be2f1e8137adde6baae4ecb9e4e4ba985c9
MISC metadata.xml 356 BLAKE2B e28aba8830da5e0c372cc7090736a5a90c208af79c6fe338e8bf96ef79e17afa05cdabdb48ca172d57fd34203c66ff7e3be4ce4c043b14c0e9694639512a82f3 SHA512 67a8fd46090c3e558e7bf963277e99e11be4d2df97f4a4491a7fbc64a42f89e19af2131d13efec7370df1f27b2eb7385f59e732fae57b6ec67c47f18af8cfc72
diff --git a/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2.ebuild b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2.ebuild
new file mode 100644
index 000000000000..d5169e8a55a5
--- /dev/null
+++ b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+# The built-in ipaddress module handles the parsing of IP addresses. If
+# python is built without ipv6 support, then ipaddress can't parse ipv6
+# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
+# other words, it's completely broken.
+PYTHON_REQ_USE="ipv6"
+
+inherit distutils-r1
+
+DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
+HOMEPAGE="https://launchpad.net/${PN}"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/authres[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
+
+python_prepare_all() {
+ # The "real" config file mentions the commented one, so we point
+ # users in the right direction.
+ local oldconf="policyd-spf.conf.commented"
+ local newconf="/usr/share/doc/${PF}/${oldconf}"
+
+ sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
+ || die 'failed to update commented config file path'
+
+ distutils-r1_python_prepare_all
+}