summaryrefslogtreecommitdiff
path: root/mail-filter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
commit4c506c69909bdb43fda5e36c79b165e404d3b86b (patch)
treeb0f9d49fd462021c82f6ebbbbafb92e1a0eae3da /mail-filter
parent81f73a84efe20818880d8c52c55a3bd067115b06 (diff)
gentoo auto-resync : 02:12:2023 - 11:00:10
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/Manifest.gzbin8377 -> 8371 bytes
-rw-r--r--mail-filter/procmail/Manifest1
-rw-r--r--mail-filter/procmail/procmail-3.22-r16.ebuild135
3 files changed, 136 insertions, 0 deletions
diff --git a/mail-filter/Manifest.gz b/mail-filter/Manifest.gz
index 62cfadc5b3bf..fed5d7b6c767 100644
--- a/mail-filter/Manifest.gz
+++ b/mail-filter/Manifest.gz
Binary files differ
diff --git a/mail-filter/procmail/Manifest b/mail-filter/procmail/Manifest
index 7e6140a666b3..7b4a06d64671 100644
--- a/mail-filter/procmail/Manifest
+++ b/mail-filter/procmail/Manifest
@@ -10,4 +10,5 @@ AUX procmail-pipealloc.diff 825 BLAKE2B 532fe5fe01b34989e6d5805c0e5e1681d0b64f38
AUX procmail-prefix.patch 5748 BLAKE2B c25d1de87d59771f959940d59195096711e70cc2a586d6eb585a58dfa96da8eb02ebe1bc03e08c0f8d6678da97d6c6016f99ae2669f4931e9cfdeb39ff23d230 SHA512 be61e6e0c89145caea1351241196c3bc986382340ecba0360d10918691cf1e35c67028a33ffaf22c83a0c747d06e58f437bf84854fc819206fa6e7bf0bbeb0d5
DIST procmail-3.22.tar.gz 226817 BLAKE2B 4fd4641abcd3a897ea19bd8f76446f88806d22649d5221f8cef6f9efc29f7fcc02c9707cbf00c32fe247f16579d28fd887d3c18c4d3a2f8877c351bf92e85866 SHA512 3d0658329a55957a8d5741e03b0853b030c4524acef30641663213aa9eefc8264f8cc2b68a00a89e5f9f0f7c916c41a42e1b6c8df562c545ba97d8ab9049a936
EBUILD procmail-3.22-r15.ebuild 3572 BLAKE2B 8a85965bf81bc4f274344b000dc588b5a9e5c2a7797f38820442c2e6c2aa76884daa7fbebff720dfbbd537ac544038d6fbbbfb8581137531859d1095cb96a919 SHA512 64861e8c5741439537261b396dbed75c02685334bcff7ea57127f7262e9670880e8f404e8ccdc9ea2fa16a4a7f8a7dbb618e0599747284c037a110408446b95c
+EBUILD procmail-3.22-r16.ebuild 3677 BLAKE2B 159144bcb42d8b8f88fc01f57814f63480105e19db13281ebd618cf04de680b3104476f7e7e4a2977b85177c07b7fc526c61e04cd35e32b8b2969e11ea10bfc4 SHA512 0de11ac3f1c8d1a8948c2841a7578cd2f518981be4ba6a05f0f310e420861927184b1a69671153b0b3f634a457de24dec81e67e1251691f9a26b40593afed795
MISC metadata.xml 171 BLAKE2B 4d68baf0e7acc5ef563cb2feeb7bc0b2d4f0bdf03780b62d338361b1da05acdbf29c94a108fe200daccc9f60bed0aa1a1be81908f36b9258d8d19d16b5e2fe36 SHA512 ef6ad959681e435a0c4fdda56f12e41a8cf24063413bcf61544c095f31eb91c30b85b1f032f2416bfac7c97ebfbe9ce1abba96805540b1568843d0ab238117d5
diff --git a/mail-filter/procmail/procmail-3.22-r16.ebuild b/mail-filter/procmail/procmail-3.22-r16.ebuild
new file mode 100644
index 000000000000..b53f7b58ddfe
--- /dev/null
+++ b/mail-filter/procmail/procmail-3.22-r16.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs prefix
+
+DESCRIPTION="Mail delivery agent/filter"
+HOMEPAGE="http://www.procmail.org/"
+SRC_URI="http://www.procmail.org/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="mbox selinux"
+
+DEPEND="
+ acct-group/mail
+ virtual/mta
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-procmail )
+"
+
+src_prepare() {
+ # disable flock, using both fcntl and flock style locking
+ # doesn't work with NFS with 2.6.17+ kernels, bug #156493
+
+ sed -e "s|/\*#define NO_flock_LOCK|#define NO_flock_LOCK|" \
+ -i config.h || die "sed failed"
+
+ if ! use mbox ; then
+ echo "# Use maildir-style mailbox in user's home directory" > "${S}"/procmailrc || die
+ echo 'DEFAULT=$HOME/.maildir/' >> "${S}"/procmailrc || die
+ cd "${S}" || die
+ eapply "${FILESDIR}/gentoo-maildir3.diff"
+ else
+ echo '# Use mbox-style mailbox in /var/spool/mail' > "${S}"/procmailrc || die
+ echo 'DEFAULT=${EPREFIX}/var/spool/mail/$LOGNAME' >> "${S}"/procmailrc || die
+ fi
+
+ # Do not use lazy bindings on lockfile and procmail
+ if [[ ${CHOST} != *-darwin* ]]; then
+ eapply -p0 "${FILESDIR}/${PN}-lazy-bindings.diff"
+ fi
+
+ # Fix for bug #102340
+ eapply -p0 "${FILESDIR}/${PN}-comsat-segfault.diff"
+
+ # Fix for bug #119890
+ eapply -p0 "${FILESDIR}/${PN}-maxprocs-fix.diff"
+
+ # Prefixify config.h
+ eapply -p0 "${FILESDIR}"/${PN}-prefix.patch
+ eprefixify config.h Makefile src/autoconf src/recommend.c
+
+ # Fix for bug #200006
+ eapply "${FILESDIR}/${PN}-pipealloc.diff"
+
+ # Fix for bug #270551
+ eapply "${FILESDIR}/${PN}-3.22-glibc-2.10.patch"
+
+ # Fix security bugs #522114 and #638108
+ eapply "${FILESDIR}/${PN}-3.22-CVE-2014-3618.patch"
+ eapply "${FILESDIR}/${PN}-3.22-CVE-2017-16844.patch"
+
+ eapply "${FILESDIR}/${PN}-3.22-crash-fix.patch"
+
+ eapply_user
+}
+
+src_compile() {
+ # bug #875251, bug #896052
+ append-flags -std=gnu89
+ # bug #859517
+ filter-lto
+
+ # -finline-functions (implied by -O3) leaves strstr() in an infinite loop.
+ # To work around this, we append -fno-inline-functions to CFLAGS
+ # Since GCC 4.7 we also need -fno-ipa-cp-clone (bug #466552)
+ # If it's clang, ignore -fno-ipa-cp-clone, as clang doesn't support this
+ append-flags -fno-inline-functions
+ tc-is-clang || append-flags -fno-ipa-cp-clone
+
+ sed -e "s|CFLAGS0 = -O|CFLAGS0 = ${CFLAGS}|" \
+ -e "s|LDFLAGS0= -s|LDFLAGS0 = ${LDFLAGS}|" \
+ -e "s|LOCKINGTEST=__defaults__|#LOCKINGTEST=__defaults__|" \
+ -e "s|#LOCKINGTEST=/tmp|LOCKINGTEST=/tmp|" \
+ -i Makefile || die "sed failed"
+
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ cd "${S}"/new || die
+ insinto /usr/bin
+ insopts -m 6755
+ doins procmail
+
+ doins lockfile
+ fowners root:mail /usr/bin/lockfile
+ fperms 2755 /usr/bin/lockfile
+
+ dobin formail mailstat
+ insopts -m 0644
+
+ doman *.1 *.5
+
+ cd "${S}" || die
+ dodoc FAQ FEATURES HISTORY INSTALL KNOWN_BUGS README
+
+ insinto /etc
+ doins procmailrc
+
+ docinto examples
+ dodoc examples/*
+}
+
+pkg_postinst() {
+ if ! use mbox ; then
+ elog "Starting with mail-filter/procmail-3.22-r9 you'll need to ensure"
+ elog "that you configure a mail storage location using DEFAULT in"
+ elog "/etc/procmailrc, for example:"
+ elog "\tDEFAULT=\$HOME/.maildir/"
+ fi
+ if has sfperms ${FEATURES}; then
+ ewarn "FEATURES=sfperms removes the read-bit for others from"
+ ewarn " /usr/bin/procmail"
+ ewarn " /usr/bin/lockfile"
+ ewarn "If you use procmail from an MTA like Exim, you need to"
+ ewarn "re-add the read-bit or avoid the MTA checking the binary"
+ ewarn "exists."
+ fi
+}