summaryrefslogtreecommitdiff
path: root/mail-filter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /mail-filter
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/Manifest.gzbin9542 -> 9375 bytes
-rw-r--r--mail-filter/pypolicyd-spf/Manifest1
-rw-r--r--mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild43
-rw-r--r--mail-filter/spambayes/Manifest5
-rw-r--r--mail-filter/spambayes/files/bayescustomize.ini171
-rw-r--r--mail-filter/spambayes/files/spambayespop3proxy.rc22
-rw-r--r--mail-filter/spambayes/metadata.xml9
-rw-r--r--mail-filter/spambayes/spambayes-1.1_beta2.ebuild42
8 files changed, 44 insertions, 249 deletions
diff --git a/mail-filter/Manifest.gz b/mail-filter/Manifest.gz
index ce1c370b0293..6752c7c33c8b 100644
--- a/mail-filter/Manifest.gz
+++ b/mail-filter/Manifest.gz
Binary files differ
diff --git a/mail-filter/pypolicyd-spf/Manifest b/mail-filter/pypolicyd-spf/Manifest
index 2cf62757f759..22c10e3bdb78 100644
--- a/mail-filter/pypolicyd-spf/Manifest
+++ b/mail-filter/pypolicyd-spf/Manifest
@@ -1,3 +1,4 @@
DIST pypolicyd-spf-2.0.2.tar.gz 38546 BLAKE2B 691cd5db37592be0ef0cda41223280e764e83802e37563f4e6c08505731118199c03d27b0bf51cec0556aa946fc6c7465fe09d3c9100c8e2582a4d85ad828495 SHA512 adcc7b30c6922894f9407edd0637b02a138623f4480ec37635475396826b457c835b3ffb599d1985e306770fe5f72404552ed705bd957e63b5c54ca3d8991673
+EBUILD pypolicyd-spf-2.0.2-r1.ebuild 1270 BLAKE2B 2b1303811bb5ce57b7dc5a13f9cafba334034612438f0923ac7cc0a404725a73b12355a9b10a94a466ab1aff37d5f761169776347775da469d008b35e85f7788 SHA512 c1cb2788c3bab4bc79e6b81a7e7b7efb64d63651632307093fbdba21e58529e73f59ae73e4ff12ebe0fdd7020adc3fdc4e22c8bc912fd27863e74ca56f99728e
EBUILD pypolicyd-spf-2.0.2.ebuild 1220 BLAKE2B f1c90045fa5cc2d2390077f3c82aebe24c5a79fcaa055a361a12d556f25ac50bb7dfcafafa5574f3fbc6d3c09a0d6c22bb4ee4b2fd153c0071460b2f08a0e461 SHA512 52cd03de6764aa154f510f2d90ea5d67c339edcbcc2acc5c49ce18fd70796e686eed201832a4891d1280fbeeb45fd5cc1c74c69e3e501e8bdad463eb30796ab4
MISC metadata.xml 356 BLAKE2B e28aba8830da5e0c372cc7090736a5a90c208af79c6fe338e8bf96ef79e17afa05cdabdb48ca172d57fd34203c66ff7e3be4ce4c043b14c0e9694639512a82f3 SHA512 67a8fd46090c3e558e7bf963277e99e11be4d2df97f4a4491a7fbc64a42f89e19af2131d13efec7370df1f27b2eb7385f59e732fae57b6ec67c47f18af8cfc72
diff --git a/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..bede125e92e7
--- /dev/null
+++ b/mail-filter/pypolicyd-spf/pypolicyd-spf-2.0.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+# The built-in ipaddress module handles the parsing of IP addresses. If
+# python is built without ipv6 support, then ipaddress can't parse ipv6
+# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
+# other words, it's completely broken.
+PYTHON_REQ_USE="ipv6"
+
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Python-based policy daemon for Postfix SPF verification"
+HOMEPAGE="https://launchpad.net/pypolicyd-spf"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/authres[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
+
+python_prepare_all() {
+ # The "real" config file mentions the commented one, so we point
+ # users in the right direction.
+ local oldconf="policyd-spf.conf.commented"
+ local newconf="/usr/share/doc/${PF}/${oldconf}"
+
+ sed -i "1 s~ ${oldconf}~,\n# ${newconf}~" policyd-spf.conf \
+ || die 'failed to update commented config file path'
+
+ distutils-r1_python_prepare_all
+}
diff --git a/mail-filter/spambayes/Manifest b/mail-filter/spambayes/Manifest
deleted file mode 100644
index c30795b9895d..000000000000
--- a/mail-filter/spambayes/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX bayescustomize.ini 3968 BLAKE2B 99ef3ccb75d00c3615deafc9879d9a2150006df37c2d0c43a61f79ab303ee41d8c5f82ca9a1c5b43ffa0ac63867e8c5a3e89c846feaa9ac1981690984d763767 SHA512 a9608e96fb50fb42f5d0ee746b0e242e465ad072f5c449ab3298b438f314806a24610f56b7dc33473ac6bae14f0c6ad7481699b12a7fc8cc4069fc7736689441
-AUX spambayespop3proxy.rc 580 BLAKE2B 414149415c4f0b4529cdd404c6a9851ff0e233c2d68250b503947f6c9712ee36851328e777696858cae6e113fe2347cad046c9b131ec0f1e18084a4f32fce922 SHA512 414e087a9096eb05453aa57c16563b21045b049354b37aeb0b23915550993cef110650f1283b8cfd31509d58441ca5a55bbe40de8570b6b552fd424edc09ec03
-DIST spambayes-1.1b2.tar.gz 1001993 BLAKE2B 71d5d1f900f144e83844e25e8fa72f2ce99cb4248263f056ebbe65f949172aecea40e7f68164f44b8f5e2300d3f48b6adb3998e32bad2cb22013525222d17ac1 SHA512 0f8e88a2b7d3200fbb08a8e55f549a06530cb2068215023f079bf2f4e399f2f7850bf4e9f01addb6a48f1e41a75872cc3909ca76b7567e2c93a9701bec7b2a39
-EBUILD spambayes-1.1_beta2.ebuild 890 BLAKE2B ca1dc35aae8f0c67e25db4535578d53176f94cdf8f994956a2ff0b2a097d1d11dfe53b7533923b3993c3394463527396ae9ed8d930f72124256a76a4ae8fdbd9 SHA512 6d29acc56f2d851e6845667324a5fac12c2b58c3c1fde971b54ac5dd9978bc5cd78b4bd2a34363b632648f3c2bfa590f5b3ee14adb3d6c3375013b051f068478
-MISC metadata.xml 300 BLAKE2B 5c5d0f1fee6cdfeaa64711764815f4d56af882ac8bf8745a702bfb9ab73f1a9b3b8800f55285cebe4735faaa5c76d44dada70585526321588872a0354f563458 SHA512 70cd147426080843aa4be83710c922d59fdf446e59b273808a3cbb856f8940fe1b4fc32fc62da65e57e142aa4b4efe761c636dd40aef2b5f950f263d72718598
diff --git a/mail-filter/spambayes/files/bayescustomize.ini b/mail-filter/spambayes/files/bayescustomize.ini
deleted file mode 100644
index b4eadc7a0a57..000000000000
--- a/mail-filter/spambayes/files/bayescustomize.ini
+++ /dev/null
@@ -1,171 +0,0 @@
-[CV Driver]
-build_each_classifier_from_scratch: False
-
-[Categorization]
-ham_cutoff: 0.2
-spam_cutoff: 0.9
-
-[Classifier]
-max_discriminators: 150
-minimum_prob_strength: 0.1
-unknown_word_prob: 0.5
-unknown_word_strength: 0.45
-use_chi_squared_combining: True
-x-experimental_ham_spam_imbalance_adjustment: False
-x-use_bigrams: False
-
-[Hammie]
-train_on_filter: False
-
-[Headers]
-add_unique_id: True
-classification_header_name: X-Spambayes-Classification
-clue_mailheader_cutoff: 0.5
-evidence_header_name: X-Spambayes-Evidence
-header_ham_string: ham
-header_score_digits: 2
-header_score_logarithm: False
-header_spam_string: spam
-header_unsure_string: unsure
-include_evidence: False
-include_score: False
-include_thermostat: False
-include_trained: True
-mailid_header_name: X-Spambayes-MailId
-notate_subject:
-notate_to:
-score_header_name: X-Spambayes-Spam-Probability
-thermostat_header_name: X-Spambayes-Level
-trained_header_name: X-Spambayes-Trained
-
-[Storage]
-cache_expiry_days: 7
-cache_messages: True
-cache_use_gzip: False
-ham_cache: /var/lib/spambayes/pop3proxy-ham-cache
-messageinfo_storage_file: /var/lib/spambayes/spambayes.messageinfo.db
-no_cache_bulk_ham: False
-no_cache_large_messages: 0
-persistent_storage_file: /var/lib/spambayes/hammie.db
-persistent_use_database: dbm
-spam_cache: /var/lib/spambayes/pop3proxy-spam-cache
-unknown_cache: /var/lib/spambayes/pop3proxy-unknown-cache
-
-[TestDriver]
-best_cutoff_fn_weight: 1.0
-best_cutoff_fp_weight: 10.0
-best_cutoff_unsure_weight: 0.2
-compute_best_cutoffs_from_histograms: True
-ham_directories: Data/Ham/Set%d
-nbuckets: 200
-percentiles: 5 25 75 95
-pickle_basename: class
-save_histogram_pickles: False
-save_trained_pickles: False
-show_charlimit: 3000
-show_false_negatives: False
-show_false_positives: True
-show_ham_hi: 0.0
-show_ham_lo: 1.0
-show_histograms: True
-show_spam_hi: 0.0
-show_spam_lo: 1.0
-show_unsure: False
-spam_directories: Data/Spam/Set%d
-
-[Tokenizer]
-address_headers: from to cc sender reply-to
-basic_header_skip: received date x-.*
-basic_header_tokenize: False
-basic_header_tokenize_only: False
-check_octets: False
-count_all_header_lines: False
-generate_long_skips: True
-mine_received_headers: False
-octet_prefix_size: 5
-record_header_absence: False
-replace_nonascii_chars: False
-safe_headers: abuse-reports-to date errors-to from importance in-reply-to message-id mime-version organization received reply-to return-path subject to user-agent x-abuse-info x-complaints-to x-face
-skip_max_word_size: 12
-summarize_email_prefixes: False
-summarize_email_suffixes: False
-x-extract_dow: False
-x-fancy_url_recognition: False
-x-generate_time_buckets: False
-x-pick_apart_urls: False
-x-reduce_habeas_headers: False
-x-search_for_habeas_headers: False
-
-[URLRetriever]
-x-cache_directory: url-cache
-x-cache_expiry_days: 7
-x-only_slurp_base: False
-x-slurp_urls: False
-x-web_prefix:
-
-[ZODB]
-cache_size: 2000
-event_log_file:
-event_log_severity: 0
-folder_dir:
-ham_folders:
-spam_folders:
-zeo_addr:
-
-[globals]
-dbm_type: best
-proxy_password:
-proxy_server:
-proxy_username:
-verbose: False
-
-[html_ui]
-allow_remote_connections: localhost
-default_ham_action: ham
-default_spam_action: spam
-default_unsure_action: defer
-display_adv_find: False
-display_headers: Subject From
-display_received_time: False
-display_score: False
-ham_discard_level: 0.0
-http_authentication: None
-http_password: admin
-http_user_name: admin
-launch_browser: False
-port: 8880
-rows_per_section: 10000
-spam_discard_level: 100.0
-
-[imap]
-expunge: False
-filter_folders: INBOX
-ham_train_folders:
-move_trained_ham_to_folder:
-move_trained_spam_to_folder:
-password:
-server:
-spam_folder:
-spam_train_folders:
-unsure_folder:
-use_ssl: False
-username:
-
-[imapserver]
-password:
-port: 143
-username:
-
-[pop3proxy]
-allow_remote_connections: localhost
-listen_ports:
-remote_servers:
-
-[smtpproxy]
-allow_remote_connections: localhost
-ham_address: spambayes_ham@localhost
-listen_ports:
-remote_servers:
-spam_address: spambayes_spam@localhost
-use_cached_message: False
-
diff --git a/mail-filter/spambayes/files/spambayespop3proxy.rc b/mail-filter/spambayes/files/spambayespop3proxy.rc
deleted file mode 100644
index f2cfe40eddc9..000000000000
--- a/mail-filter/spambayes/files/spambayespop3proxy.rc
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-customize_ini=/etc/bayescustomize.ini
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting SpamBayes POP3 Proxy daemon"
- export BAYESCUSTOMIZE="${customize_ini}"
- start-stop-daemon --start --quiet --background --pidfile /var/run/spambayes.pid --make-pidfile --exec /usr/bin/sb_server.py
- eend $?
-}
-
-stop() {
- ebegin "Stopping SpamBayes POP3 Proxy daemon"
- start-stop-daemon --stop --quiet --pidfile /var/run/spambayes.pid --name sb_server.py
- eend $?
-}
diff --git a/mail-filter/spambayes/metadata.xml b/mail-filter/spambayes/metadata.xml
deleted file mode 100644
index b6d87d151069..000000000000
--- a/mail-filter/spambayes/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="pypi">spambayes</remote-id>
- <remote-id type="sourceforge">spambayes</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/mail-filter/spambayes/spambayes-1.1_beta2.ebuild b/mail-filter/spambayes/spambayes-1.1_beta2.ebuild
deleted file mode 100644
index ed11cd3e9d9b..000000000000
--- a/mail-filter/spambayes/spambayes-1.1_beta2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_P="${P/_beta/b}"
-
-DESCRIPTION="An anti-spam filter using on Bayesian filtering"
-HOMEPAGE="http://spambayes.sourceforge.net"
-SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz
- mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="PSF-2.2 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND="
- dev-python/bsddb3[${PYTHON_USEDEP}]
- dev-python/lockfile[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodoc -r *.txt contrib utilities testtools
-
- newinitd "${FILESDIR}"/spambayespop3proxy.rc spambayespop3proxy
-
- insinto /etc
- doins "${FILESDIR}"/bayescustomize.ini
-
- keepdir /var/lib/spambayes
-}