summaryrefslogtreecommitdiff
path: root/mail-filter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /mail-filter
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/Manifest.gzbin8715 -> 8715 bytes
-rw-r--r--[-rwxr-xr-x]mail-filter/spampd/files/init-r10
-rw-r--r--mail-filter/spf-engine/Manifest1
-rw-r--r--mail-filter/spf-engine/spf-engine-2.9.2-r4.ebuild77
4 files changed, 78 insertions, 0 deletions
diff --git a/mail-filter/Manifest.gz b/mail-filter/Manifest.gz
index b6289917aca2..c3e667a1c43c 100644
--- a/mail-filter/Manifest.gz
+++ b/mail-filter/Manifest.gz
Binary files differ
diff --git a/mail-filter/spampd/files/init-r1 b/mail-filter/spampd/files/init-r1
index b6402e4b5b55..b6402e4b5b55 100755..100644
--- a/mail-filter/spampd/files/init-r1
+++ b/mail-filter/spampd/files/init-r1
diff --git a/mail-filter/spf-engine/Manifest b/mail-filter/spf-engine/Manifest
index 3404ab9a4937..03ff7680d20c 100644
--- a/mail-filter/spf-engine/Manifest
+++ b/mail-filter/spf-engine/Manifest
@@ -1,3 +1,4 @@
DIST spf-engine-2.9.2.tar.gz 52737 BLAKE2B 39d6c9831ef3ea489f2910fcbcaec9b2bed627f02459e20826166f04a2fe895aecf83768a3446a037e4231cc317ee277f6ff8e9030c72d8819739f6af889d632 SHA512 fe1fe82411ed4d6fcfadccd6ccc9fbd36372b4676051aafa5984740cba862336b00567576b3e32451cd24b0cfcd992d7dfdee33f0cf65a35f4009837e99b8f98
EBUILD spf-engine-2.9.2-r3.ebuild 2783 BLAKE2B 6cb7071aada85cd6c41aa2285404dc86d130dec6a4082ea5c26369f6b47431cbbd3f9ef05c54bc8c9d6bd8977cf6c8b04cc9d2e9a4527d8b06e6eb4f9df03ff7 SHA512 f6b78f1ca2bb3c33b2477719f8f6d8c3645444afa51ec58fce86504ade28ff830b38bb7b00cf70c616a9834080f468e24a2d215188e753c284927a06b3207aec
+EBUILD spf-engine-2.9.2-r4.ebuild 2721 BLAKE2B e895e288e1bea3877167d237c54d18b0a0968b04eee8118bb998f68e50565600231256ce28976ee3f4c26a857e0118b29e66e71a9edf6471cff7d61a4aed87ea SHA512 125c1895b5e8584c38bee6470f899a3cf0be7ab7acd18bc3f0416100ac41546e33510549ad9a4392d69a12ea0d5ef3549dd2d6afdfaabbaaa0190e3cb891f99c
MISC metadata.xml 351 BLAKE2B 896ff35eb02fb2dc7a81f61d7698c72566061e15a43773b24655f12840e47b9f84ab98778498da1418b74007309fff3257de8b5ea06f60b4d358633ebfec12cd SHA512 e592b10d44514d4f5ac34295b727a58659d82d41e100c97c96f7881d0e189311e30aa2527a32d92ae1cbefea55aa722d39c7c36c3d3b259fc3b1df04bd9b075f
diff --git a/mail-filter/spf-engine/spf-engine-2.9.2-r4.ebuild b/mail-filter/spf-engine/spf-engine-2.9.2-r4.ebuild
new file mode 100644
index 000000000000..250e794e33cd
--- /dev/null
+++ b/mail-filter/spf-engine/spf-engine-2.9.2-r4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_8 python3_9 python3_10 )
+
+# The built-in ipaddress module handles the parsing of IP addresses. If
+# python is built without ipv6 support, then ipaddress can't parse ipv6
+# addresses, and the daemon will crash if it sees an ipv6 SPF record. In
+# other words, it's completely broken.
+PYTHON_REQ_USE="ipv6(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Policy daemon and milter for Postfix SPF verification"
+HOMEPAGE="https://launchpad.net/spf-engine"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyspf[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/authres[${PYTHON_USEDEP}]"
+
+DOCS=( CHANGES policyd-spf.conf.commented README README.per_user_whitelisting )
+
+python_prepare_all() {
+ # The "real" config file mentions the commented one, so we point
+ # users in the right direction.
+ local oldconf="policyd-spf.conf.commented"
+ local newconf="/usr/share/doc/${PF}/${oldconf}"
+
+ sed -e "1 s~ ${oldconf}~,\n# ${newconf}~" -i policyd-spf.conf \
+ || die 'failed to update commented config file path'
+
+ distutils-r1_python_prepare_all
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Remove the milter files that are installed by default. The milter
+ # isn't quite ready:
+ #
+ # * The README says it's experimental not well-tested.
+ # * There's no documentation for its configuration parameters
+ # (expecially the UserID).
+ # * The configuration file is hard-coded to /usr/local.
+ # * The paths in the systemd service file are hard-coded to /usr/local.
+ # * We need to write an OpenRC service script for it.
+ #
+ # These are all eventually doable, but I'm not willing to commit to
+ # making the milter work before upstream is.
+ #
+ rm "${ED}/usr/bin/pyspf-milter" \
+ || die "failed to remove ${ED}/usr/bin/pyspf-milter"
+ rm -r "${ED}/usr/lib/systemd" \
+ || die "failed to remove ${ED}/usr/lib/systemd"
+ rm -r "${ED}/usr/etc/init.d" \
+ || die "failed to remove ${ED}/usr/etc/init.d"
+ einfo "The milter component of spf-engine is still deemed experimental"
+ einfo "and not well-tested by upstream. It's missing configuration"
+ einfo "files, service scripts, and documentation. In other words, it"
+ einfo "doesn't work yet."
+
+ # The setuptools installation routing always works relative to
+ # python's prefix, so that when installing locally you wind up
+ # with paths like /usr/local/etc. However for system installs
+ # that does the wrong thing and puts the sysconfdir at /usr/etc.
+ # Here we move it to the right place.
+ mv -v "${ED}/usr/etc" "${ED}/" || die 'failed to relocate sysconfdir'
+}