summaryrefslogtreecommitdiff
path: root/mail-filter/scmail/scmail-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /mail-filter/scmail/scmail-1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'mail-filter/scmail/scmail-1.3.ebuild')
-rw-r--r--mail-filter/scmail/scmail-1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/mail-filter/scmail/scmail-1.3.ebuild b/mail-filter/scmail/scmail-1.3.ebuild
new file mode 100644
index 000000000000..2b3e44ca9c5b
--- /dev/null
+++ b/mail-filter/scmail/scmail-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils fixheadtails
+
+DESCRIPTION="a mail filter written in Scheme"
+HOMEPAGE="http://0xcc.net/scmail/"
+SRC_URI="http://0xcc.net/scmail/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-scheme/gauche"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-*.diff
+ ht_fix_file tests/scmail-commands
+ # replace make -> $(MAKE)
+ sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}/usr" \
+ SITELIBDIR="${ED}$(gauche-config --sitelibdir)" \
+ DATADIR="${ED}/usr/share/doc/${P}" \
+ install
+ dohtml doc/*.html
+}